Input Switches EStop config incorrect?

11 years 11 months ago #29104331 by Bryan
It seems that the system I am running is behaving differently than the User manual suggests with regard to the EStop input. The firmware and Manual I have are listed below:

I have an AX2550 with the following firmware:
RoboteQ v1.9d 10/23/07
{
RoboEnc v1.7 02/01/05
03
OK

I believe I have the latest manual ( dev.roboteq.com/dev1/documentation.html ) AX2550 Motor Controller Users Manual Version 1.9b June 1, 2007.

If I look up the Input Switches Function definition on page 147 of the manual it says that enabling EStop requires the first 2 bits to be set to a 01 (binary). However, testing of the unit shows that EStop is only active for the 00 setting (the default and the manual says Input Disabled) and disabled for the 01 setting?

Can someone else who is using the EStop functionality comment on their settings?

We are monitoring the settings of the device and its EStop condition using the actual EStop input bit (using ?I), the Status Register (^89), looking at the controller AlphaNumeric display to monitor the estop condition, and verifying the configuration parameter (^04) using hyperterminal.

Thanks
Bryan

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29171083 by cosma
Replied by cosma on topic Re:Input Switches EStop config incorrect?
00 is the correct setting for Estop to be enabled.
02 is the value needed to enable Estop.

The manual has an error. We will fix it at the next release.

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29187967 by Bryan
Replied by Bryan on topic Re:Input Switches EStop config incorrect?
I'm sorry, but I don't understand your response?

>>00 is the correct setting for Estop to be enabled.
Ok, so you are saying our observation is correct for the first 2 bits of the Input Switches Function.

>>02 is the value needed to enable Estop.
I have no idea what you are referring to here?

>>The manual has an error. We will fix it at the next release.
Thank you.

Bryan


Please Log in or Create an account to join the conversation.

11 years 11 months ago #29194668 by cosma
Replied by cosma on topic Re:Input Switches EStop config incorrect?
storing 02 at that location will cause the estop to be enabled

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29310904 by Bryan
Replied by Bryan on topic Re:Input Switches EStop config incorrect?
I stored an 02 at that location (^04 02) and it didn't set the controller into the Estop state. It simply changed its configuration.

Could you provide me with the entire command string you are suggesting will put the controller into an EStop state?

Thanks
Bryan

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29327077 by cosma
Replied by cosma on topic Re:Input Switches EStop config incorrect?
Puting the 02 only serves to enable the estop input on the DB15 connector.

If you want that the controller enters in estop mode under software control then you could use the 02 setting but you would have to have the estop input wired to ground.

Note that the "02" config is meant to enable the estop input, not to force the controller in estop under software control. Sending a command to stop the motors (!a00, !b00) is a far simpler and efficient way to do achieve the same.

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29341541 by Bryan
Replied by Bryan on topic Re:Input Switches EStop config incorrect?
Ok, I think i have it now..

Input Switches function ^04
For bits 1:0
00 - Input as Emergency Stop
01 - Input disabled
10 - Input Enabled as normal input
11 - Input as invert command

I was never trying to force the controller into estop via software. I just didn't understand your responses.

Thanks

Please Log in or Create an account to join the conversation.

11 years 2 months ago #29525052 by roboteq
I have the AX2550HE 2-2-3 v1.9f

I found that:
^04 02 disabled the e-stop.
^04 01 made the e-stop momentary (stopped only when held low).
^04 00 made the e-stop work properly (i.e. requires that you reset the controller to resume normal operation.)

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.326 seconds