AX 500 problems

9 years 7 months ago #29525547 by ConstantineT
AX 500 problems was created by ConstantineT
Hello there.
I just go an AX 500 motor controller.
I have connected all harware and install all the approp software included for windows 7 (which I run with).
I have connecvted the card to my laptop using a serial to usb adapter.
However I run in 2 problems
For a start if I try to connect to run the controller in analog mode and skip the pc connection , just connecting the joystick to the approp ports on the 15 pin connector,when I power the usit , the light indicator flashes in 2 time intervals for rs232 mode and not 4 time intervals for analog mode. So first question is cant I operate the controller with out connecting at all to the pc?

Second problem is that when connected on the laptop and try to run the roborun software, I get an error in the beginning saying to address to the correct port as port 1 isnt correct, then I change the port from the menu on the right to port 3 which turns the green light saying that this is the correct port, however I get an error 8020 and pressing yes to this closes the program. Whats the deal here?

I run these on a brand new laptop Windows 7, 64 bit, and I use a adaptor to connect from rs232 to usb on the laptop.

I cannot get any responce at all in both laptop, or direct joystick connection.

Please help asap as I need to run the controller and Iam already late.

Thank you very much

Kostas

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525549 by roboteq
Replied by roboteq on topic Re:AX 500 problems
The controller will not automatically enter the analog mode.

You first must configure the operating mode to analog with the PC utility.

Then, beware that the analog mode will be enabled only after the two inputs are centered (ie 2.5V present at the input pins)

Regarding the PC utility, we have never received report of this error.

There have been problems when using a non-english version of Windows. In these cases, users managed to make it work by changing the language settings of windows.

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525551 by ConstantineT
Replied by ConstantineT on topic Re:AX 500 problems
Hello. Thanks for your reply.
This is English version and not other of windows 7.
If I cant connect to the pc I cant change the controller either to analog. so I need a solution for this.
can you help please?
thanks

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525553 by ConstantineT
Replied by ConstantineT on topic Re:AX 500 problems
ALSO another thing.
I have tried to repair reload the ROBORUN.
While set up the software, somewhere in the middle an error window pops up saying

Module C:\\Windows\\SYSWOW64\\APPWIZ.OCX failed to register
H RESULT -2147467259
CONTACT YOUR SUPPORT.

Will that be the possible reason why the roborun doensnt work?
you can carry on the set up after this or skip and stop, I have carried on. But roborun runs into the error discribed on first post.

Thanks

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525555 by ConstantineT
Replied by ConstantineT on topic Re:AX 500 problems
I also read some sections of roborun problems and in a post the guy had the same error.
here is rthe error
\"Run-time Error \'8020\': Error reading comm device

Iam using the same Prolific converter from rs232 to usb

will that be the prob?

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525557 by roboteq
Replied by roboteq on topic Re:AX 500 problems
We have no idea why you are getting the windows errors you are reporting. If another user resolved a similar problem by changing the USB to serial adapter, try the same.

The other method for changing configuration is to use a terminal emulation software, like hyperterm. Hyperterm is no longer part of Vista and Win7. So you need to find and install a third party product.

When connecting the controller, you should see a continuous string of data. Send (Enter) 10 times and this will stop the data stream and the controller will be in serial mode.

Then, to change from serial to analog, send ^00 03. Then restart. See manual for how to change other parameters.

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525559 by ConstantineT
Replied by ConstantineT on topic Re:AX 500 problems
Hello. It was the usb adapter what was causing the problem.
I changed it to a different make and it works fine now.

I will be doing some motor tests and come back for some input.

I also connected a joystick directly and it workas fine.
The only thing I ve noticed was the acceleration adjustment.
It didnt seem to have an effect what ever was setted low or high, I tried various adjustments save to the controller then run to see if it was any different , but I could not notice ant effect at all.
Iam going to go carefully throu this tomorrow and at the weekend, maybe Iam missing something.

I have one question. Does the acceleration setting suppose to have effect in decelleration as well?

thanks for your support

Kostas

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525561 by roboteq
Replied by roboteq on topic Re:AX 500 problems
Deceleration and acceleration rates are the same.

But the AX500 will not brake the motion when decelerating. This is because unlike our other models, the AX500 does not support synchronous rectification.

So when decelerating, the mechanical friction of the motor is the only thing that will slow down the motor.

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525563 by ConstantineT
Replied by ConstantineT on topic Re:AX 500 problems
can you recomend a similar controller of yours that includes braking as well?
I am looking for a controller to use it running 2 Maxon motors 20-90W at 12 vdc, for a remote camera head.
The wireless option is a good thing.
I neeed a controller that can handle rapid invertion of motors and of cource also have the option of accel decell adjustment.
Which one do you recoment?
Thanks

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525565 by roboteq
Replied by roboteq on topic Re:AX 500 problems
The SDC2130 would do a very good job in this application. See dev.roboteq.com/dev1/brushed-dc-motor-co...-dc-motor-controller

You could connect a minature receiver directly to it for remote control. dev.roboteq.com/dev1/tech-support/spektrum-radio-support . You can also use any other type of RC radio.

If you ever want to operate in closed loop position mode, depending on the quality of your feedback sensor, you will be able to achieve precise and smooth positioning. See the video at www.youtube.com/watch?feature=player_profilepage&v=xptBWoCq6Rc . The demo uses a linear actuator but would work the same with a rotating head.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.160 seconds