SDC2130 Encoder

9 years 5 months ago #29525597 by JesseR
SDC2130 Encoder was created by JesseR
Hello, I\'m trying to get use an encoder with the SDC2130 and I could use a hint!

I have a single encoder, wired to the \"Encoder 2\" inputs (DIn5=10, DIn6=15), as well as power (+5v) and ground. I believe its working, because I see the DIn5 and DIn6 indicators light on/off in the Roborun Plus (Rev 1.2 2/12/11) utility if I move the encoder. I\'m trying to make sure the encoder works and is going in the right direction before I connect the motor, so no motor is currently connected.

However, I don\'t see anything happen other than the DIn5 and DIn6 indicators. Should I see the \"Counter 2\" value change, if I display it in the chart? I also tried mapping the Encoder 2 as \"Feedback(2)\", then graphing Feedback 2 in the chart, but neither moves with the encoder. I tried setting Motor 2 to closed-loop-speed as well, and graphing the motor\'s speed, but that was also zero. (just as a test, I manually set Counter 2 to a value via the console, and that value did display in chart, but it never changed. As a second test, I wired a pot to Analog-2, set that as Feedback-2 instead of the encoder, and in that case the Feedback-2 line does move as I would expect in the chart.)

Am I missing a step? How do I get the encoder to increment the counter, or otherwise display?



Thanks for any leads!!
Jesse

My board reports firmware: Roboteq v1.2 RCB100 01/16/2011
(I don\'t see any SDC firmware downloads on the software page.)
Attachments:

Please Log in or Create an account to join the conversation.

9 years 5 months ago #29525599 by roboteq
Replied by roboteq on topic Re:SDC2130 Encoder
Pls try the firmware attached to this post dev.roboteq.com/dev1/online-forum/troubl...not-working#29525589

Please Log in or Create an account to join the conversation.

9 years 5 months ago #29525603 by JesseR
Replied by JesseR on topic Re:SDC2130 Encoder
Thanks for your quick response! Upgrading to that firmware changed the behavior, I now see Counter 2 move, as well as Feedback 2!

Looking to the future, should I keep on the lookout for an officially distributed version of the firmware on the download page, and upgrade to that when it comes out? (i.e., is this a beta release, or is ok to stick with this version?)

Thanks!
Jesse

Please Log in or Create an account to join the conversation.

9 years 5 months ago #29525613 by JesseR
Replied by JesseR on topic Re:SDC2130 Encoder
I have noticed one more issue, though it is easy to workaround - the pop-up menu for \"Loop Error Detection:\" for Motor 2 seems to be changing the value for Motor 1. Neither pop-up affects the value for Motor 2.

Please Log in or Create an account to join the conversation.

9 years 5 months ago #29525627 by JesseR
Replied by JesseR on topic Re:SDC2130 Encoder
OK Another bit of data here - I was noticing that even with the new firmware, the Counter (?C) is always 0 (even if I move the encoder with my hand) until I run RoboRun+ and hit \"Load Configuration\" (or allow it to auto-load on connect) in the RoboRun+ program.

I narrowed it down to a single query - if you query the encoder mode (ie, send ~EMOD) then the encoders begin to count ticks! (you don\'t need to set anything, just the query does the trick!)

cheers,
jesse

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.143 seconds