No feedback from Hall sensors on Brushless motor (HBL2350)

9 years 3 days ago #29526027 by andrewhannay
Hi All,
For some reason, I\'m not getting any feedback from my hall sensors. In Open loop mode the motor spins very smoothly but there is no RPM being detected from the hall sensors. The motor would not spin at all until I had correctly wired up the hall sensors as the info supplied was wrong (hall1 was swapped with hall2) so I know the hall sensors are working correctly and the hall sensors input must be working also. A few months ago I seem to remember it all working ok but I recently updated the firmware and now I have run into these problems. I can\'t go back to a previous version of firmware as the Roborun+ software does not recognise or display any motor \"Power Output\" options. Also the latest Roborun+ software seems to cause the Motor controller to loose connection every so often.
Hope you can help me please.
Regards,
Andrew

Please Log in or Create an account to join the conversation.

9 years 3 days ago #29526029 by jppedroni
Hi everyone,
I also found that hall info is wrong, hall 1 being swaped with hall 2.
My problem is the following: I found the correct hall/phase configuration, my motor spins smoothly on both directions in open loop mode, but the lectures of position and speed from the hall sensors and the desired rotation direction have oposite signs, so I can\'t close the loop. Any suggestions?
Regards,
Juan

Please Log in or Create an account to join the conversation.

9 years 3 days ago #29526031 by roboteq
First, if you get motor motion, this means that the hall sensors work and that they are correctly connected to the controller.

If the reported speed using the hall sensor is the oposite of the motor command, then you need to make the motor turn the other way. To do this, swap any two hall sensor wires and then find the matching motor wiring.

There was a firmware problem that was fixed in july 2011, which caused the hall counter to only work for motor 1 (motor2 would report the same value). This is fixed in the latest revision of the firmware.

However, there is no known problem with speed capture. We have one user reporting that speed capture would not work but we were not able to replicate this problem in our lab.

Please Log in or Create an account to join the conversation.

9 years 3 days ago #29526033 by andrewhannay
Is there something possibly wrong with the config. I noticed at one point that the config error flag was set.
\"Reset Defaults\" doesn\'t help.
What makes me suspicious of firmware or configuration setting, is, after power up, when controlling the motor direct from hyper terminal the controller does not respond to the !M command. I have to send a ~PWMF query first(not command) and after that it will respond as normal. I discovered this by looking at the comms when Roborun+ starts up and narrowed it down to this one query command.

Please Log in or Create an account to join the conversation.

9 years 1 day ago #29526041 by andrewhannay
Ok, have had to resort to using optical encoders and now I can control the motor in speed feedback and position feedback mode and the correct rpm info is being received from the encoders. So, questions :-
1) I still see no rpm info from the hall sensors, why?
2) I cannot use !m until I have sent ~pwmf - this makes no sense.
3) I\'m using an encoder with 200 pulses/phase/revolution (or 200 cycles/revolution or 800 edges/revolution). I set up encoder 1 with 200 Pulses/Rev and this gives me the correct RPM when sending the motor command. However, I noticed that the rpm displayed seems to loose its granuality such that while trying to maintain the motor at 200 rpm, the rpm displayed is showing 175,200 or 225.
4) The command limits are -1000 to 1000 but my motor is capable of 4000 rpm. How do I achieve higher rpm, do I have to fool the controller into thinking I have a higher pulses per revolution encoder and scale everything else accordingly?
Sorry for all the questions, hope you can help.

Please Log in or Create an account to join the conversation.

9 years 1 day ago #29526047 by roboteq
If you had problems with the hall sensor speed measure. This would not be fixed by using the encoder as speed sensor. To view the speed in the chart, you need to enable the encoder speed measure and not use the hall sensor speed measure.

It makes no sense that commands would not work until you change the PWF configuration. Pls report which controller model you have and which firmware revision is installed.

The granularity issue is due to the fact that speed is measured by counting the number of pulses inside a short time interval. To get a higher granularity, you would need either a higher count encoder or the firmware would have to measure over longer periods. Since the control loop is evaluated every 1ms, we have opted for the rapid measure even though this means a granularity that is limited. For most applications, this is not noticeable.

To make the -1000 to +1000 command drive your motor from -4000 to +4000, change the Max RPM configuration from the default 1000 to 4000

Please Log in or Create an account to join the conversation.

9 years 1 day ago #29526049 by andrewhannay
Please note I am just reading the PWMF not changing it. Only after I have done this will the controller respond to my motor commands.

Hardware is HBL2350
Firmware is v1.2 RCB500 08/14/2011

Many thanks

Andrew

Please Log in or Create an account to join the conversation.

8 years 11 months ago #29526053 by andrewhannay
Hi,
I hate to do this but....
Bump.
I\'m a bit worried by the silence.
Andrew

Please Log in or Create an account to join the conversation.

8 years 11 months ago #29526055 by roboteq
we are investigating. Pls stand by.

Please Log in or Create an account to join the conversation.

8 years 11 months ago #29526067 by andrewhannay
Hi,
I have some more information for you.
I have had to persevere with this as the mechanical hardware is waiting for me to finish the control software which puts me into the rather unconfortable position of being on the critical path for completion of this project.

This is related to direct control via hyperterminal.
As before, from a power up I have to issue a ~pwmf query (READ not WRITE), it now appears that while in position mode the motors turn extremely slowly. Only after I have sent a ~eppr query (READ not WRITE) do the motors turn at the correct Default Position Velocity.

So recap:-
1) Power up.
2) Motor does not respond to !M 100 0
3) send ~pwmf
4) Motor now responds to !M 100 0
5) set motor speed back to 0 via !M 0 0
6) clear encoder count back to zero via !C 1 0
7) Switch to position mode (via ^MMOD command)
8) send !M 100 0 and motor turns really slowly
9) send !M 0 0 and motor turns really slowly back to 0
10) send ~eppr
11) send !M 100 0 and motor turns quickly
12) send !M 0 0 and motor turns quickly back to zero

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.143 seconds