Losing USB connection to SDC 2130

11 years 7 months ago #29526827 by pahan
I\'ve tried different combinations of machines cables and firmware. The only version of firmware that worked for me with proper closed loop speed control is from 03/06/2011 that I got from one the threads on the forum here. None of the later versions that I\'ve tried worked, either with this usb problem or with closed loop control issues or both.

Changing firmware for me clearly resolves this issue, on this firmware I had not seen it even once, on latest it occurs almost immediately.

One more thing to note is that the latest firmware identifies as a different USB device for some reason than the old versions, don\'t know if this has anything to do with it.


Please Log in or Create an account to join the conversation.

11 years 7 months ago #29526829 by mbalazs
FWIW... we switched to a USB to serial cable that plugs into the serial port on the board and it has solved our issues. This is not the ideal solution but a solution...

Please Log in or Create an account to join the conversation.

10 years 8 months ago #29527727 by egarms

I am having similar problems as are described here. I have the USB connected from the SDC2130 (Rev .15, according to the sticker on it) to my computer. Then I turn on the controller. The computer recognizes the controller and it shows up in Roborun. After a short period of time (between about 10 seconds and a minute) the connection is lost. The controller remains powered on, but the USB light on it is turned off. I have the latest firmware. Please let me know if there is a solution to the problem. My USB cable is pretty long.

I am also having problems with connecting the serial port to my Spektrum AR500 receiver. Plugging in the serial port will sometimes cause the SDC2130 to turn off. I am not sure if these problems are related.

Thank you.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.055 seconds