AX1500SC won't work until restarted/reconnected

11 years 1 month ago #29526784 by Anonymous
I am using an AX1500SC to control a single linear actuator using an analog signal. I have noticed that sometimes when I switch the controller on the motor doesn't start moving and the status light does not blink at all. The power light does come on. I will have to either switch the controller on and off a few times, or disconnect and reconnect the power supply and switch the controller back on for it to work. This issue never happens when it is connected to a PC, only when connected to the analog signal.

Please Log in or Create an account to join the conversation.

11 years 1 month ago #29526785 by Roboteq
We have never observed this. There is a protection scheme that will prevent the motors to start moving until the command pot is centered but this should not prevent the LED from flashing.
We'll take a closer look but let us know if you can determine a pattern when this problem occurs for you.

Please Log in or Create an account to join the conversation.

11 years 1 month ago #29526786 by Anonymous
After looking through the manual I did find the statement the manual saying that the analog input must be at 2.5 V for the controller to be activated after its been reset or powered on, and after testing this I have found that it does resolve the problem. However, the command signal that I am sending to the controller is a sinusoidal function created by a signal generator and I do not want to have to set it so that it will reach 2.5V everytime I switch it on. Is there any way to bypass this protection?

Please Log in or Create an account to join the conversation.

11 years 1 month ago #29526787 by Roboteq
You can disable that feature with roborun. You will need to set this parameter by hand using the console:
Enter "^05" and send the result should be a 2 digit even number ending with 0, 2, 4, 6, 8, A, C, E
add 1 to that number. For example if you read 22, make it 23 and send that value to the controller with the same command" ^05 23
reset the controller for the change to take effect.

Please Log in or Create an account to join the conversation.

11 years 1 month ago #29526788 by Anonymous
Your solution works! Thanks a lot!

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.121 seconds