Problem commanding SDC2150 with RC input

8 years 1 month ago #29527229 by houshun.poh
I recently purchased a RoboteQ SDC2150 2x20A, 50V Closed-Loop Brushed
DC Motor Controller.

I am having some problems of controlling the motor reliably from the radio.

I am using a Futaba radio set 9CHP transmitter, and R114F reciever.

The reciever is connected via the 15 pin connector, +5V, and GND to
one of the reciever channel to power the receiver.

I also tried power the reciever with an external +6V supply that is
ISOLATED from the +5V supply of the cotnroller.

Signal, GND of channel 1, and 2 of the receiver to DIN1 (RC ), and DIN 2 (RC2).

The VMOT, GND (power Stage), and the PwrCtrl, GND (logic stage) are
connected to SEPERATE 12V battery.

When the power stage is switched off, through the Roborun software I
can see the pulse is captured reliably with values of about 1000 to
2000 ms when I move the sticks around.

However, when the power stage is switch on, the captured value
fluctuates from 0 to the commanded value, and the motors just
stutter. The problem is worst with RC1. Since the DIN1, RC1, and DIN2, RC2, ANA2, I have disabled all the encoder, and analog voltage read function. I tried setting DIN to active high and also low, figuring there may be some resistance change on the pins but no change to the behaviour.

With only one channel disabled, the situation is better, motor sometimes still stutter at low trottle. Commanding the controller through USB works fine.

The current firmware I am running is v1.2 RCB100 10/19/2011.

Have anyone experience this issues and have a possible solution? Thank You very much

Please Log in or Create an account to join the conversation.

8 years 1 month ago #29527231 by roboteq
Replied by roboteq on topic Re:Problem commanding SDC2150 with RC input
This sounds like an electrical noise problem.

Make sure that the radio ground is taken from the 15-pin connector and not from the battery terminals.

Look for other ways noise could make it to your radio and/or the RC input wires.

You do not need to change anything in the DIN or PIN settings. Reset them to the factory default, if in doubt.

Please Log in or Create an account to join the conversation.

8 years 1 month ago #29527237 by houshun.poh
I tried a number of test to try to diagnose the problem

1. I tested the receiver with a servo, it did not stutter.
2. Tested the controller with the power stage switched off, it read the PWM fine.
3.I tested with the power stage switched on, but motors disconnected worked fine also.

Only when the motors are connected the problem resurface.

4. Next I soldered 0.1uF cap across the motor, it does not seem to correct the problem.

5. The 15 pins break out cable is only breaks out the +5V, RC1, RC2, the RC header are connected to the 15pins connector via 3 wire ribbon cable. I make another breakout for the +5V, RC3, RC4, and RC5, with three wire twisted. The receiver seem to be work in those channels.I am not sure whether RC1, and RC2 are faulty.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.071 seconds