HDC2472S not working (and not recognized)

9 years 2 months ago #29528949 by e-novia

I bought two Roboteq DC controller.
These are the serial numbers:
1) H72 PCB 2.1 1347 S/N I-00047
2) H72 PCB 2.1 1347 S/N I-00010

I developed a script that read a current/torque setpoint every millisecond via Can-Bus (by CAN-RAW readings) and set it with GO-command by using your PID-Torque Mode. This script is set to be always running (it's running from the start-up).

Controller #1 (00047) works very good and I tested it with a DC motor.
So I tried to do the same thing on controller #2, by using the same script and the same configuration.

Controller #2 (00010) hasn't the same behavior as #1.
From the first time I powered it on, the controller seemed to lock after few seconds (it sent only few can-message). I used also a led as an output. On controller #1 it blinks every second, while on controller #2 it locks on a status (ON or OFF).
So I tried to do other test and I've also updated successfully the firmware of the controller to the last version (HDC24XX-Firmware-Update-v12-101013).
Now the application Roborun+ recognizes the controller only for two second and so a message "Controller has been lost" appears after this serial outputs:
FID=Robotqe v1.3 RCB500 10/10/2013
I tried both USB and RS232 mode, but it's the same. So now I'm also not able to use the controller.

How can I solve on controller #2?

Thanks in advance for your answers.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.049 seconds