SDC2160: serial safety causes motor to spin dangerously

6 years 5 months ago #29529034 by andycavatorta
I'm using 7 SDC 2160s for a project at the Royal Opera House in London. They all have identical configurations, from the same file. All are connected to identical motors, encoders and inertial loads. They are all issued the same commands.

I've set up RS232 safety (3000ms), as I'm having trouble with reliable RS232 comms. I need them to stop if they lose communication.

Six of the controllers respond as expected. One starts forcefully spinning both channels in a fast/slow alternating pattern.

I'm trying to troubleshoot this issue ASAP, because we have performances coming up soon. So perhaps you can help me understand.

When serial is removed and RS232 safety kicks in, is the firmware supposed to just cut power, or to actively use PID to halt the motor? If it doesn't just cut the power, is there a way to make it do that? Any idea why this one of seven is misbehaving and what I might do to resolve the issue?

- thanks
- ac

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529036 by Griffin Baker
Try resetting the controller to factory defaults. After the reset, read the configuration, then load the profile configuration to the controller. Then save to controller. Depending on how you may have loaded the profile, it can determine whether or not the controller actually saved the new settings.

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529039 by andycavatorta
Thanks Griffin!
I just had this happen again last night on 3 different controllers, not the first one I mentioned. So the question is no longer "What is different about this one controller?". The question is "How do I get the RS232 safety feature to work right 100% of the time?".

What I need to determine ASAP is whether this is a broken feature of the boards or whether this is somehow fixable. Do you have any QA data on this?

Again, the behavior is that removing removing the RS232 connection by removing the cable or terminating the program that sends commands sometimes results in a board's attached motors spinning out of control. This behavior disappears when I turn off RS232 safety and reappears when I enable it.

This feature is important to our application because we're using it to cover for occasional RS232 comm problems with the boards.

- thanks again

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529040 by Griffin Baker
The RS232 safety is the watchdog timer function unless it is something else I am not aware of. The watchdog timer looks at the serial commands that you send. If you tell a motor to go forward +500 and it doesn't see a command every 1 second( default value), then the watchdog timer goes to sleep and the motor output is cut off. If there is a command seen within that 1 second or whatever value you set except 0, then the motor will continue to spin.

So by saying you are turning off the watchdog timer, means to me that you are simply allowing the motor commands to be active until given the stop command.

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529042 by andycavatorta
Hi Griffin,
The previous posting talked about two conditions.

1) Using RS232 watchdog timer: In this case, the cessation of sending commands causes the motors under closed-loop control to spin out of control as much as 10% of the time.

2) Not using RS232 watchdog timer: In this case, controllers execute the last closed-loop-speed command until another is sent. This is correct. But when RS232 communication is lost ( which is too often ), the motors cannot be stopped.

Having had several controllers freak out at the removal of the UDS cable *again* today, I'll rephrase my question:

"RS232 safety is definitely, absolutely a broken feature on the SDC2160 under at least the closed-loop-speed configuration that I use, causing far more potential harm than it prevents. Is there any way to make this feature work as advertised?"

If it's helpful, I can upload or email my configuration file.

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529049 by roboteq
We are not aware of any issue with the rs232/USB watchdog but we will verify again.

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529050 by roboteq
The problem may be that you have the pulse enabled in the command priority list. If that is the case, and if you have not disabled the pulse capture, it can happen that the encoder give pulses that are captured as a command and produce an erratic motion. We have seen this happen before.

In the command priorities, verify that you have Serial, None, None.
Change the pulse configuration to "Disabled" for all pulse inputs

Please Log in or Create an account to join the conversation.

6 years 5 months ago #29529056 by andycavatorta
I think you've got it, Griffin. Thanks much! Now off to finally nail the RS232 stability issues.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.234 seconds