HDC2472 DONT TURN ON

6 years 4 months ago #29529289 by FIGUEIREDO
Replied by FIGUEIREDO on topic HDC2472 DONT TURN ON
The greens and white wires are disconnected and insulated. When i connect only the yellow and the black wire with the other ones disconnected the "power led" turns on and fast ( 2 seconds ) they slowly turn off ... this happened every time i try to turn on ... i read the battery voltage and it still 25 volts..

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529290 by Griffin Baker
Replied by Griffin Baker on topic HDC2472 DONT TURN ON
It definitely sounds like something is wrong.

Please send us an email to This email address is being protected from spambots. You need JavaScript enabled to view it. and request for an RMA number. In the email include that these 4 units are powering on for a second and then shutting off.

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529291 by Griffin Baker
Replied by Griffin Baker on topic HDC2472 DONT TURN ON
I spoke with our production tech. He said it turns on at 28V. The unit I have is an older version which turns on at 18V, but all of the new ones power on at 28V or higher. So try adding one more battery in series.

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529292 by FIGUEIREDO
Replied by FIGUEIREDO on topic HDC2472 DONT TURN ON
Man, you saved the day.. Thank you ... with 36 volts they worked fine. I didnt try this before because i coldnt find this at manual.

Can i use 36 volts with the controller ( yellow and black wires ) and 24 volts at big red wires to use 24 volts motors?


Really thanks for your attention.

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529293 by Griffin Baker
Replied by Griffin Baker on topic HDC2472 DONT TURN ON
I've checked the manufacturing specs, and it does state 28V min. I checked the datasheet, and the listed there is 20V, which is incorrect and we will get that updated. Our sincere apologies for the discrepancy.

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529294 by Griffin Baker
Replied by Griffin Baker on topic HDC2472 DONT TURN ON
Yes. As long as the controller sees the 36V, you should be okay. So 36V on your power control will power on the controller, and the big red wire 24V can be used for the motor output.

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529314 by FIGUEIREDO
Replied by FIGUEIREDO on topic HDC2472 DONT TURN ON
Griffin,

everything is great. This new controller is amazing. Thank you for your attention.

Please Log in or Create an account to join the conversation.

6 years 4 months ago #29529315 by Griffin Baker
Replied by Griffin Baker on topic HDC2472 DONT TURN ON
You are very welcome and wish you continued success with your application.

Please Log in or Create an account to join the conversation.

3 months 6 days ago #29535067 by KD
Replied by KD on topic HDC2472 DONT TURN ON
hi i had the same exact problem but mines gone a little farther with me trying to diagnose the issue even over email with one of roboteq support members but to shed some light on what i had happen...
i bought a used second hand but yet was new HDC2472S  single motor controller that the previous owner or the guy i bought this from had told me he upgraded the motor to a duel channel and when i got it. wasn't even used before from what i could tell.. but anyways i too hooked mine up to 24v on main battery and then another 24v up to the control wires and every thing worked great via RC that i had through RS232 connection up until i decided to do a firmware update via the usb to usb connection to the pc. after it said it had successfully upgraded from version 1.8 to 2.0 i lost all control and connection with the hdc2472 and its been a battle to get mine working with my LED lights back on which i know through serial port to my pc connection i cannot find my com port automatically but yet i can connect to something through manuel and then when i try to re install another firmware after it completes doing the reset it gets stuck on waiting to restart controller... i was instructed to power cycle the controller down when its trying to restart the controller but i did and nothing happens i have  tried all sorts of things to shutting off the main completely unplugging the main battery and as well as from grounding out the  control switch but the only thing is i dont have a black wire able to hook up to my switch  its only got 2 hookup tabs on it that i put the battery on one and then the control yellow wire on other and it was working to shut off controller before upgrading to 2.o when i lost all control and lights and communication from what i see.... i also figured out by adding another battery to try seeing if it would help with more power and so i had 36 volts on mine and the lights all came back on but the controller still never responded to any communication between my pc  and so after i hooked up my rs232 to try and do the firmware update cause its been reset and erased so right now i think it has nothing and im left with the log saying start up script not found when its awaiting for a restart after it resets it every time i try... 

one more thing i also lost all lights again after i first hooked up the rs232 to my controller and with 36 volts for the yellow wire isn't cutting it for the power lights to be on now and but it still manually can connect to my com ports for when i try installing the firmware manually not automatic so any advice would be greatly appreciated im about to give up but migth purchasde your GDC 3660e now 

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.137 seconds