Trouble with AX2550 - motors only go one direction

3 years 2 months ago #29533163 by snackwog
Hi everyone,

First time here....Hopefully, you guys out there are much more knowledgeable than we are and can offer advice. My son and I used a AX-2550 to control wheelchair motors on a radio controlled lawnmower that we built this summer. It was a project that I suggested that we build in hopes to spend good father son time together and to make something cool. So here's our trouble...

We used a standard RC radio and receiver and connected to the AX2550. Tank style drive. We used Roborun to set a few settings on the controller that seemed correct to us. It all worked out well when we finally hooked up. The RC lawnmower worked very well for a couple of weeks. Suddenly it behaved strangely over the weekend. We shut it down and tonight I started troubleshooting. I figured it had to be the transmitter, receiver or controller. Roboteq being so robust I figured it was probably the last thing to fail. But now, I think yes it might be.

I hooked it up to Roborun (note this is the older utility, not Roborun+). On the "run tab" I was able to discover a few things. First, everything seems pretty normal. That is, at least that the controller connects and behaves normally with Roborun. I can control both motors from Roborun and they run. But only in one direction. Both motors only go in one direction. This was the same problem when we were demo-ing the lawnmower and driving it around. Suddenly it wouldn't go forward. So I do not think it is the receiver or transmitter. I believe it is the AX2550. This is particularly discouraging for us since he was about to take it in and show it to his engineering class at college.

Before I start tearing stuff apart, I was wondering if anyone has any suggestions? Clearly the AX2550 still has much functionality so it can't be something catastrophic. It talks to Roborun and can run the motors (in one direction). It seems to work absolutely normally except that for the one direction thing. This is the case on both motors/channels.

Would anyone have any suggestions?

I have some basic electronics knowledge but I'm no wiz. I'm willing to try any ideas. Anyone got any? I would be very grateful to get this thing going again. Thanks for any help!

Please Log in or Create an account to join the conversation.

3 years 2 months ago #29533164 by snackwog
Quick update:

I'm continuing to play with it and noticed that it was A/B separate mode instead of mixed. We used mixed for thw mower. In separate mode, I noticed that both motors will only go in one direction. But in 'mixed' one of the motors will then go both directions. But only the one motor. The other still only goes one direction. Not sure what this means but thought I would add this detail.

Please Log in or Create an account to join the conversation.

3 years 2 months ago #29533165 by snackwog
I'll post this for anyone down the road who looks at this with a similar problem....

I called in and spoke with Blake in tech support. First off, Blake was awesome and very helpful. Very patient with a newbie like myself. We worked with the Roborun utility and went through some basic steps to diagnose the problem.

Likely answer: blown MOSFETs on one side of the system. I didn't open it up or anything (it's currently buried in our build) but I may eventually open it and see if there is obvious physical damage.

I'm going to replace the controller with a newer model from Roboteq. I think they have a great product and customer service.

Thanks Blake!

Please Log in or Create an account to join the conversation.

3 years 1 month ago #29533247 by Erik
How can a mosfet blow up? Was that a very old controller or so? Or is the wiring a bit crappy or so? Was it properly connected with the diode over the fuse?

I read the whole story and didn't learn anything from it, so for me that's wasted time.

Please Log in or Create an account to join the conversation.

3 years 1 month ago #29533252 by snackwog
I didn't say it was "blown up". I said it was blown. Like a light bulb perhaps. But, yes, a blown MOSFET was the cause in the end. I opened the unit up and one of the MOSFETs was very obviously fried. There was clear physical damage to it and about an inch diameter of carbon residue from it on the board. The controller is maybe 15 years old. The wiring and insides of a Roboteq controller are very neat and tidy. The MOSFET just decided to go. Could have been an over-voltage or over-current situation perhaps. Hard to know. It only takes a split second for it to happen. I replaced the controller. I might try to fix the old one with a new MOSFET but likely not. I think its death took a few other components with it and those are surface mount on the board. Very challenging to try to replace those.

Please Log in or Create an account to join the conversation.

3 years 1 month ago #29533253 by Erik
I see, well it was an old controller anyway. But blowing the controller is one of my nightmares because if i have to change the motors it means a whole new design of the lawnmowing robot and much work. The problem is that lawns are not perfectly flat so it takes a lot of power for the robot to get over bumps.

I use an fbl2360 and so far so good, my fear is to blow a motor and also end up with a dead controller if that happens.

The only thing i have to change is the steering which is too direct but that can be done by software i hope.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.168 seconds