FBL2360 RS232 Unresponsive Channel

5 years 6 months ago #29533299 by jma

I am using 4 FBL2360 controllers, which each control an identical motor configuration. They control two different brushless motors, both with hall sensors. They are communicating with a Speedgoat xPC through RS232 communication for running tests through Simulink.

When we run the Simulink simulation for the first time, all the motors spin properly at the correct speeds. However, whenver another simulation is run after, the second motor channel for all of the controllers is unresponsive. Even when resetting the power to the controllers, the second motor channel remains unresponsive. When testing the controllers through USB with the RoboRun software, the second motor channel works properly with 2 of the controllers.

All of the controllers are running the same firmware version. I have made sure all of the fuses are intact. I am using CAT5 cable for all signal/communcation wires.

Could the problem be buffer related? Any help would be appreciated.


Please Log in or Create an account to join the conversation.

5 years 5 months ago #29533349 by Erik
Have you tried to reset the malfunctioning systems and re-install them? And what connector are you using to communicate with the speedgoat pc? I would make sure all the wiring is done as good as can be, If you fear EMI you can test it by using alufoil to protect, or use ferrite cable...i had big issues with my laptop and the roboteq untill i changed my computer power transformer for one with a ferrite core cable...that round thing in the cable can make a lot of difference.

Last week my arduino got EMI from a brushless pwm fan but after i let the fan run wrapped in alufoil it worked perfect.

I think you have issues with that speedgoat pc grounding, but i'm no expert...just trying to help.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.049 seconds