FBL2360 Torque Mode : Sinusoidal Swithcing doesn't work.

5 years 9 months ago #29533337 by TeddyTheBear
I am developing an E-Vehicle using FBL2360 FW: v.1.8b FBL2XXX. At the beginning, I set switching mode to Trapezoidal in Torque Mode. It worked properly. However, the controller doesn't work well while the vehicle is starting to move. I have tried to optimize PID parameter and also acceleration/deceleration. But nothing works.

Therefore, I think I should try Sinusoidal switching mode. But it doesn't work at all. Motors rotate randomly every time when the controller has been turned on. I think it might search for zero reference. Moreover, the motors rotated in randomly direction. I have followed all instructions in manual. But it still doesn't work. Could you give me any suggestion to solve this problem?

Thank you very much for your kind support.

The following is information about my BLDC motor:
- Number of pairs: 10
- Sensor: Hall Sensor
- Max. Amp: 17A
- Max. Speed 600 rpm

Please Log in or Create an account to join the conversation.

5 years 9 months ago #29533356 by blake
When in sinusoidal commutation the controller is using FOC (field oriented control) for torque. These require different gain settings. Please refer to page 108 of our User manual for further instruction. We have a full description of FOC HERE

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.062 seconds