SDC2130 Motor 2 problem

1 year 1 month ago #29534765 by VRTECH
Dear,
I use SDC2130 with 2 DC motors and encoders.
I use input ENC1A/B and ENC2A/B of the db15 pinout.
I also use the digital input DIN 3 and 4 to reset the software scripted counter.
I have tried 3 differents control and i have the same problem. All of the tthre controller are Firmware 01/08/2018 1.8d (the last like bought).
In the script, at the beginning i load the count position from internal EEPROM/FLASH and works ok.
The motor 1 is working OK.
The motor 2 make random problem like (stopping and restart during movement, stop and reset the controller. Stop and controler is freezed,need to power off/ON.

I use many of controllers since many years (maybe 30 controllers since 3 years.).
I have make setting in contrlleur configuration like (disable analog guard, PWM disabled, analog disabled.
I only use Serial usb link (the serial is not in fault i think, i have put timeout at 0 and since many years it works for same installation. The cable is good manufactured with shield).
So i attach my script to this mail. Maybe something is wrong, but i make script since 3 years and every thing works well. Event more this script is quite simple.
The motors are driven in open loop so it is not a problem of PID.
The motors runs in 24Volts at 1 ampère. So there is no heavy load to the controler.
Please take some time to help me to solve this situation.
Best regards.

File Attachment:

File Name: GC_2VENCINIT.txt
File Size:5 KB
Attachments:

Please Log in or Create an account to join the conversation.

1 year 1 month ago #29534767 by LROBBINS
Replied by LROBBINS on topic SDC2130 Motor 2 problem
Have you tried physically swapping the motors so that the one you had on channel 2 is on channel 1? Have you checked all of your physical connections carefully?

I recently had erratic errors of an added Allegro motor current sensor and it turned out to be neither a problem in the controller nor in the sensor. It was a slipped pin in an Anderson PA75 that was giving a high resistance and variable contact in one motor lead. (How it unhooked from the spring steel pin latch I don't know - but the steel strip seems mis-aligned and the pin slipped back again more than once since then.)

I sure lost a lot of time trying to find faults in my script, my power distribution module with the current sensors etc. and with the HDC2460 controller before noticing what I should have checked right at the start.

Please Log in or Create an account to join the conversation.

1 year 1 month ago #29534768 by VRTECH
Replied by VRTECH on topic SDC2130 Motor 2 problem
Thank you for your reply.
Yes i have inverted both motors, and the same result. When i use only the motor 2 it works.
So i have checked wire between each motor and i have found a 9MOhms impedance.
I have change all wire for motor and sensor. Now it works.
Finally like you say, we are thinking that the script is not well but finally it comes from wire.
So in conclusion : Test the wire continuity and also the isolation bethween each other wire.

Please Log in or Create an account to join the conversation.

1 year 1 month ago #29534769 by LROBBINS
Replied by LROBBINS on topic SDC2130 Motor 2 problem
Glad I could help and glad you found the solution.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.109 seconds