MBL 1660 N failed DFU then > restart looping > RS232 garbage

4 months 2 weeks ago #29535387 by Lucas
We have been using MBL1660 for a couple of years. For our script to run we require FW1.8. We have just purchased two new units.
When updating FW we used the latest v2.1

Used the same PC as on all previous occasion ( win 10 etc )
Used USB DFU mode ( always worked in the past )
Unit did not recover from FW update
Upon restarting Roborun+ 2.1 controller not found
checked this forum & built a RS232 cable on a startech USB-RS232 converter
restarted Roborun+ 2.1 but it could not find the MBL1660 console reads restarting ( as a loop )
checked forum - suggested a RS232 FW upload with "power cycle" when green bar loading
tried RS232 FW2.1 upload - errors
tried RS232 FW1.8 upload - errors

UPDATE CONTROLLER FIRMWARE WINDOW reads ;

Checking file: C:\roboteq_FW\MBL1XXX-Firmware-Update-v18d-010818.zbin
Extracting: MBL1XXX-FIRMWARE-UPDATE-V18D-010818.BIN...Done.
Extracting: F3_MBL1XXX-FIRMWARE-UPDATE-V18D-010818.BIN...Done.

Searching for device...
Checking COM5...device found.

Controller found on COM5.
Resetting the controller...done.
Waiting for device restart...error.
Device starting string not detected.

UPDATE CONTROLLER FIRMWARE WINDOW read stop.

Roboteq+ log reads using clipboard copy comand

"0?    ? ?????? ?????????????    ?????????trn

NB in the console the ? character read as arrows and faces etc

I dont think its the cable or USBR232 converter as we bought two new MBL1660 units and the 2nd ( unflashed ) unit reads fine over the RS322

Any ideas please
 

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.064 seconds