Error running Roborun+

9 years 8 months ago #29525417 by Michael Burton
I have recently been unable to run the Roborun+ application.

I get an error thet says Visual C# Command Line Compiler has stopped working. Once I close that window it pops open again with the same error and I close it again and get an unhandled exception error.

It says
An error occurred creating the form. See exception.innerexception for details. the error is: Object reference not set to an instance of an object.

at roborunplus.my.myproject.myforms.create_instance_[T](TInstance)
at roborunplus.my.myproject.myforms.get_Roborun()
at roborunplus.my.myApplication.OnCreateMainForm()

at Microsoft.visualbasic.applicationservices.windowsformsapplicationbase.onrun()
at Microsoft.visualbasic.applicationservices.windowsformsapplicationbase.doapplicationmodel()()

Please Log in or Create an account to join the conversation.

9 years 8 months ago #29525423 by Michael Burton
I have tried a reinstall. I get an error on the reinstall that reports appwiz.ocx failed to register.

Please Log in or Create an account to join the conversation.

9 years 8 months ago #29525443 by Michael Burton
I have continued to try to track this down. It looks like RR+ is trying to use a font that is not on my system. I am not sure but it looks like I let an uninstaller remove what it thought was an unused font. Now RR+ opens the font the open fails but is not checked and then it uses the handle and gets an error.

Please Log in or Create an account to join the conversation.

9 years 8 months ago #29525471 by Michael Burton
I have now done a clean install of Windows Vista and reinstalled Roborun+ and still have the same issue. I need help.

Please Log in or Create an account to join the conversation.

9 years 7 months ago #29525501 by Michael Burton
After all the updates were loaded the Roborun+ utility runs without error. I was informed that one of the .net updates was not installed and caused the error. It must have been corrupted in the previous installation.

It works without error now.

Please Log in or Create an account to join the conversation.

9 years 3 months ago #29525835 by neumotiv
Replied by neumotiv on topic Re:Error running Roborun+
I had a very similar (identical) problem with Win7TPC ThinPC RTM) because .NET3.5.1 SP1 does not install on TPC; everything fine with Win7 full version.

Please Log in or Create an account to join the conversation.

8 years 9 months ago #29526837 by LauraArnold
Be careful, and test the hell of it with the chair on blocks and the wheels clear. I feel comfortable with the idea of scripts changing the max speed, or the current limit, and a few other things like that, but once it\'s outputting a throttle value to the power stage then you need some trust that it won\'t screw up.

video converter

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.211 seconds