Roborun+ Error on Windows 7 32 bit

7 years 7 months ago #29527789 by okutkan
Hi everyone
Roborun+ utility runs on my win8 machine without any problem.
But when I try to run it on windows 7 PC. I get an error.
(see attached screenshot)

I think this is the part where program enumerates com ports and ads them to list.

Probably trying to add com port with the same name which is already in the list.

Simply adding
\"list.ContainsKey(str2))\"
control into the code will solve the problem.
Attachments:

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527791 by okutkan
Sorry I couldn\'t attach screenshot
Attachments:

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527795 by Griffin Baker
Replied by Griffin Baker on topic Re:Roborun+ Error on Windows 7 32 bit
Seems this is something new I haven\'t seen yet. By chance, is this windows 7 being dual booted with windows 8?

Try uninstalling the program and reinstalling. See if you get the same error.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527799 by okutkan
No its not dual boot machine.

As far as I can debug this is a problem with com port names. I guess roborun uses some old way to get comport names available on the system. The api used by roborun returns unused/old/deleted comport which may have the same name with the real comports on the system.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527801 by Griffin Baker
Replied by Griffin Baker on topic Re:Roborun+ Error on Windows 7 32 bit
okutkan wrote:

No its not dual boot machine.

As far as I can debug this is a problem with com port names. I guess roborun uses some old way to get comport names available on the system. The api used by roborun returns unused/old/deleted comport which may have the same name with the real comports on the system.


So under your device manager, does it allow you to go into the settings to change the com port number? Also, I couldn\'t see clearly if the port number that is listed on your device manager is the same that the roborun+ software is using. You can see what com port the software uses at the very bottom of the browser.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527803 by Griffin Baker
Replied by Griffin Baker on topic Re:Roborun+ Error on Windows 7 32 bit
I\'ve looked at the picture you submitted, and it shows you are using com4 in your device settings, but the roborun+ is showing it is using com5. You\'ll need to change your com4 to com 5, and hopefully the error should go away.

I believe the settings you\'ll want to set for it is the following.

Baud rate 9600
Data bits 7
Parity Even
Stop bits 1

Sorry, I wasn\'t able to edit sooner, due to the spam flood error for posting too quickly.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527805 by okutkan
Roborun says \"com1, com2, com3,com5,com6 found\" when it starts but no com4.

I will try to add screen shot later tonight. I am on my way to home ;-)

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527807 by Griffin Baker
Replied by Griffin Baker on topic Re:Roborun+ Error on Windows 7 32 bit
okutkan wrote:

Roborun says \"com1, com2, com3,com5,com6 found\" when it starts but no com4.

I will try to add screen shot later tonight. I am on my way to home ;-)


So what it seems is that the screenshot shows Roboteq Motor Controller(Com4). This needs to be changed to Com5 since the roborun+ shows Com5 is being used. This is seen at the bottom of the roborun+ browser on the bottom right corner. I believe it says Com5 is closed.

In device manager, open your Roboteq Motor Controller (com5) port and you want to change it to use Com5. If the roborun+ software is saying it is using a different com port, then you\'ll need to switch your port settings to match what roborun is telling you it is trying to use.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527809 by okutkan
Here is the new sysmptoms.
- mdc2250 unplugged.
- I start roborun+
- It starts normally and says \"Found:Com1,Com3,Com4,Com8,Com9\" on the bottom left and \"ComX is closed\" message cycles through 1 to 9 on the bottom right.

When I check device manager only com1 is visible
- I connect mdc2250 to usb port
- mdc2250 appears as com 3 in device manager.
- As soon as it appears on device manager roborun+ gives the exact same error message: \"An entry with the same key already exist\"
- I close roborun
- and Change Roboteq Motor Controller (com5) port to Com4
- start roborun
- same error message.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #29527811 by Griffin Baker
Replied by Griffin Baker on topic Re:Roborun+ Error on Windows 7 32 bit
Try reinstalling the software. I\'ll try to see if I can replicate the same problem on my end in the meantime.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.126 seconds