PC Utility has killed RS232 port

5 years 8 months ago #29530027 by beerbot
As I reported previously, the PC Utility locked up the RIO when I chose the scripting tab.
karman reported the same result in the "Microbasic Transfer" thread on this Forum.

I find now that it also has impacted the RS232 port.

If I power cycle the RIO with the RS232 cable connected and minicom active on my Linux desktop, I see
on the minicom screen:

Starting ...
FID=Roboteq v1.3 RIOAHRS 03/17/2014

After that no RS232 communication is possible. Prior to running the PC Utility, full RS232
access was available via minicom after the RIO booted.

Is there a fix?

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530031 by TechSupport
page 13 of the datasheet tells you how to send the commands in minicom.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530034 by beerbot
You did not answer my question.

The PC Utility has caused the RIO to stop responding to RS232 communication.

Is there a fix?

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530035 by TechSupport
Try rebooting the PC and turn off and back on the Rio. This has never been an issue.

Please Log in or Create an account to join the conversation.

5 years 8 months ago - 5 years 8 months ago #29530063 by TechSupport
Reflashing with the firmware via comport(RS232; not USB) will fix issue. For those reading this post, I've attached the firmware to reflash to.

In the Robonav utility, click on update firmware via comport.
In the upper left corner select manually assign comport.
On the right side, select the correct comport.
Browse for file.
click "program"
While message says "Waiting for device to restart", turn off power to device and power back on.
This will then reflash the Rio and rio AHRS devices.
Attachments:

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530072 by beerbot
Following the steps indicated by TechSupport above, the RIO is back!

Note that when accessing the RIO via RS232, Hardware Flow Control must be set to "No." Similarly, if using a serial library like pySerial over RS232, set rtscts=0.

Accessing the RIO from the Raspberry with riocom/minicom over /dev/ttyAMA0, either Hardware Flow Control setting works.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.144 seconds