Amps Trigger Activated

5 years 8 months ago #29530036 by embenz
Hello,

I keep receiving the "Amps Trigger Activated" signal though my amp trigger is set to 20.0 Amps and Limit is set to 30.0 Amps and when I use the read motor amps command it reads at most 0.7 Amps.

Any hints? Am I missing something?

-Emily

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530037 by TechSupport
Replied by TechSupport on topic Amps Trigger Activated
Perhaps you may have set a trigger action or a parameter.

You can try making sure to set the amps trigger action to no action, and make sure no checkbox next to it are selected if applicable.

If you can, please upload a screencapture of the fault. Try sending us this picture in a zipped folder as a majority of the times uploading a non-zipped files will not show up in the post.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530038 by embenz
Replied by embenz on topic Amps Trigger Activated
No set trigger action... I receive FM=64 which corresponds to an Amp Trigger Activated.

When I click one of my built in limit switches, I get 96 or 80 so I know those are working.
Attachments:

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530039 by TechSupport
Replied by TechSupport on topic Amps Trigger Activated
Interesting. Just so you are aware, you can use an action preset in the analog for your forward and reverse limit switches since you are using them as feedback. Action on min, and action on max.

Are you using a pot to control the feedback? I ask because I didn't really see anything for how you are driving the motor otherwise as motor command.

I'm thinking there maybe something else since you are using the closed loop parameters. Is your loop error detection enabled or disabled?

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530040 by embenz
Replied by embenz on topic Amps Trigger Activated
I am using a pot to control the feedback.
Close loop error detection is enabled to the default value.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530041 by TechSupport
Replied by TechSupport on topic Amps Trigger Activated
Try the following.

Set closed loop error detection off and see if the FM still reports back 64.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530042 by embenz
Replied by embenz on topic Amps Trigger Activated
Still reports back to 64. I even verified I had closed loop error detection turned off with ~CLERD.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530043 by TechSupport
Replied by TechSupport on topic Amps Trigger Activated
Go to configuration tab and click on save profile to disk. this will allow you to save your controllers configuration to your pc.

Then click on "reset to defaults" to reset back to factory default settings.

Then read back from controller.

Then in the console tab, do the following commands and queries.

^rwd 0 - this will disable watchdog timer
!G 1 10 - gives motor a command of +10
?fm

to stop motor send !G 1 0

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530044 by embenz
Replied by embenz on topic Amps Trigger Activated
Thank you for your help but Amp Trigger is no longer important to our controller use. Thank you.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #29530045 by TechSupport
Replied by TechSupport on topic Amps Trigger Activated
The amp trigger should not be active. But the steps I had provided below was to see if that was a real fault or something else causing that to appear.

I'm not sure how old your controller is, but the latest firmware build is 11/21/14.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.174 seconds