Setting up a SDC2130 in RC Speed Control

5 years 4 months ago #29530597 by JasonT
My end goal is to have my Roboteq SDC2130 commanded by RC and take advantage of some encoders for speed control.

This means on my DB15 I will need to have the RC signals connected to pin 11 (RC4) and pin 12 (RC3) since the encoder inputs are shared with the other RC inputs.

Everything seems to be working in Roborun+. Meaning I can control the motors with the sliders, the indicators for the encoders and RC inputs seem to be blinking correctly but I do not have control from my Spektrum remote.

I'm thinking that there's something in the configuration of the motor controller that I do not have set right. Under the Spekrum RC heading I left everything default except I changed the Joystick Select field on Command 1 to 3 and the same field on Command 2 to 4. I can see the input lights flashing but I am seeing no response from the motors. Is there somewhere I have to set what "Command 1" and "Command 2" do that I am not seeing?

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530598 by JasonT
A little update. I was originally looking at the Spektrum RC portion while it appears I should have been looking at the Pulse Input section.

Running the range calibration on pins 3 and 4 is showing that the roboteq is seeing my joystick but no action is being taken. The capture type for these are set to pulse with with input use of pin 3 being motor command 1 and pin 4 being motor command 2.

In the Command Priorities section I have Pulse set to 1, Serial set to 2 and 3 and 4 disabled.

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530600 by TechSupport
For now do the following. Go back to the serial being first priority and pulse as second.

You'll need to disable all pulse inputs that are not being used. Pulse inputs 1 and 2 are enabled by default. Failure to do so will result in pulse not working until those connections are made and it sees a signal.

If you do a reset to defaults, you can wire up on pulse inputs 1 and 2 and power controller without the pc and it should work right away. Pulse input 1 drives motor 1 and pulse input 2 drives motor 2. If you are using different inputs, disable these completely, and uncheck the checkboxes next to the action area. These are for selecting which motor channel your action is is for whether it is motor command or feedback.

Save settings to controller after changes have been made.

Go to run tab, and select the "Mute" checkbox. This will mute the serial and if all settings are correct and inputs are wired into the controller properly, then the "Pulse" status led should turn on red. If this occurs, then you should be able to drive it a motor command.
The following user(s) said Thank You: JasonT

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530601 by JasonT
It looks like it was the other pulse inputs not being used.

Thank you for the help!

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.151 seconds