RIOX-1216 and Pulse input

5 years 5 months ago #29530750 by Kayoku
Hello,

I'm working on the RIOX-1216. I try to capture PWM signal on the Pulse Input 1 of the RIOX, but it's not working.
The interface is a bit different that on roboteq controller, and I just can't disable the "Analog Input", I don't know how to disable it. In a controller, we have 3 possibility, "Disable" - "Relative" - "Absolute", but here we just have two "Relative" - "Absolute".

How can I disable Analog Input and get my Pulse Input ?

Thanks you for your answer.

PS : I don't know how it is possible too but, i was connected as "roboteq" this morning, maybe a fail ? Just for notice it.

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530751 by roboteq
Replied by roboteq on topic RIOX-1216 and Pulse input
There is an error in the configuration menu,

Changes to pulse input 1 affect pulse input 2

Save the attached menus in C:\Program Files (x86)\Roboteq\RIOX Configuration Utility\Trees

Beware that depending on the windows version, you may need to change the security settings in order to write anything to that folder.
Attachments:

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530778 by Kayoku
Replied by Kayoku on topic RIOX-1216 and Pulse input
Hi,

Thank you for your answer.
I changed the .xml files in "Trees" folder, but this is not working. I try on the pulse input 1 and the pulse input 2...
I really don't understand how to disable the analog input. I join a screen where you can see that Pulse input are disable whereas they are supposed to be activated.
Attachments:

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530779 by Kayoku
Replied by Kayoku on topic RIOX-1216 and Pulse input
You disabled the analog inputs ok but you dont need to do this. If the pulse mode is enabled, as I can see you did, then pulses will be captured.

Make sure you see the led for these pulse input flicker. This will indicate that the pulse signal is seen. Note that in pulse width mode, the pulse must be high between 900us and 2100us, and repeat at 50Hz min. Otherwise it will not be considered a valid pulse and it will be reported as 0

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530782 by Kayoku
Replied by Kayoku on topic RIOX-1216 and Pulse input
Hi,

I don't know why my account has been used for reply but ok.. why not. (Connection bug ?)
I analyzed the signal, his period is 20ms, so it's ok for the 50Hz. I try to see the signal in the Pulse Input of a controller (MDC2460S) and it works ! I don't understand why i can't on my RIOX... If you have any other idea :x

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530797 by TechSupport
We will investigate.

Please Log in or Create an account to join the conversation.

5 years 5 months ago - 5 years 5 months ago #29530799 by TechSupport
The new firmware I had did not work(0 in pulse inputs). Not sure which firmware date code came with yours, but please install this one for now while we fix the newer firmware.

I went back to the old 4/15/15 and it did work. You can disregard the values on the analog input.
Attachments:

Please Log in or Create an account to join the conversation.

5 years 5 months ago - 5 years 5 months ago #29530808 by Kayoku
Replied by Kayoku on topic RIOX-1216 and Pulse input
Hi,

Thank you for your help.
I try to install the new Firmware, and now my RIOX freeze in start, all led are activated and the board is not recognizable by a computer (USB or Serial didn't work..), did you have this problem too ?
I'm really confused about all the problem that i have, i think i'm unlucky !

Edit : Just for describe how i proceed, in first i tried to connect RIOX by Serial COM, but during the update, the RIOX didn't want to restart. After i tried by USB, and that's work ! (or at least, RIOX Configuration Utility show me that the update was successful) But the RIOX freeze.. Without any reasons.

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530817 by TechSupport

Please Log in or Create an account to join the conversation.

5 years 5 months ago #29530820 by TechSupport
Here's the latest. I have tested and it works.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.150 seconds