Cannot get FBL2360 working

4 years 6 months ago - 4 years 6 months ago #29532036 by Ferrentino
Please, help.
Weeks ago I bought a FBL2360 for developing agricultural robot.
I red fbl 23xx_datasheet paying attention.
Problem is I cannot get an output on the motor.
FBL2360 is connected to PC through USB

This is my setup & test conditions unless otherwise specified:
General setup
S.O. Windows 7 64bit
Roborun+ vers. 1.5 10/9/2015 (I know there is 1.6 ver.)
PC connection by USB cable

Roborun+ Setup
Command Priorities RS232, Analog, None

Connections
Faston tabs
Battery Power+12Vdc on VMOT, 0V on GND
PwrCtrlNC (not connected)
MotorBLDC 6 poles 1600 Kv on ch1 (W1,V1,U1) or
on ch2 (W2,V2,U2)
Hall sensor conn.(silked “Sense”)all NC
IO connectionsall NC

Test 01 – Serial input
Status LED on FBL2360 led green blinking one time repeated
Status LED on Roborun+ “Run” tab Serial
moving slider on Roborun+ , “Run” tab:
Test Result
No motor spinning
Roborun+ :
outputs values on motor
outputs 0A current on motor

Test 02 – Analog input by Analog ch1 or ch5
Connections as stated above unless otherwise specified
Input Analog ch1 or ch5
IO connections 13 and 25 to pot, 15 or 21 to central pot
Roborun+ , “Run” tab Mute checked (input switch from Serial to analog)
Status led green blinking three time repeated

Test Result
No motor spinning turning pot
Roborun+ :
outputs values on motor
outputs 0A current on motor

Am I missing somethings?
Thanks a lot for your help.

Please Log in or Create an account to join the conversation.

4 years 6 months ago #29532037 by blake
Replied by blake on topic Cannot get FBL2360 working
Hello, sorry for the delayed response.

I was just reading through your setup and do I understand correctly that your Hall sensor is not connected? If so you need to connect the Hall sense cables from your motor to the Hall inputs on the controller, otherwise your motor will not work.

Please Log in or Create an account to join the conversation.

4 years 6 months ago #29532038 by Ferrentino
Thank you Blake, very kind of you.

I read in FBL2360 datasheet:
"Open loop or closed loop speed control operation"

and more:
Multiple Motor Operating mode
...
- Trapezoidal with Hall Sensors
- Trapezoidal Sensorless (Q3/15)
...

In Roborun+ -> configuration tab -> power output frame -> Operating mode, I set Open loop and in Closed Loop Feedback Sensor
I have "other"
Cannot I operate in sensorless open loop mode?

Thank you again
Attachments:

Please Log in or Create an account to join the conversation.

4 years 6 months ago #29532039 by blake
Replied by blake on topic Cannot get FBL2360 working
If your FBL controller is v2.3 (see barcode label on bottom of the controller) then you can try sensorless operation with the latest release of our firmware (v1.6 available from downloads page of website). Be advised that this operating mode will only work with that version of controller, <v2.3 does not accommodate it. Additionally, be advised that this operating mode is not fully perfected yet, currently it doesn't have instant startup. But again if you have that version of controller feel free to try it out.

Please Log in or Create an account to join the conversation.

4 years 6 months ago - 4 years 6 months ago #29532040 by Ferrentino
Dear Blake,
I'm from Italy.
I ordered the unit 4 weeks ago and I got it 2 weeks ago : my FBL is 2.2!
It's quite strange I haven't last HW release.

When 2.3 has been released?

Best Regards

Please Log in or Create an account to join the conversation.

4 years 6 months ago #29532041 by blake
Replied by blake on topic Cannot get FBL2360 working
It was just put into production this past March. If you ordered from a distributor it is possible that they do not have any in their stock. Version 2.2 is not obsolete by any means, the hardware just isn't compatible with sensorless control.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.120 seconds