Faulty Encoder Reading from SDC2130

4 years 3 months ago #29532088 by Arunya
Hi,
I have two issues with my Encoder settings and count value.
1. Counter1 is not showing the encoder reading correctly(should show 90000 counts per cycle, but show different values that not even close to that value each time)
2. Encoder is having 22500 PPR, but i can only type 5000 (max) in Roborun+ utility.
I will be very thankful for your help.

Please Log in or Create an account to join the conversation.

4 years 3 months ago #29532089 by blake
Hello,

Please provide the datasheet for the encoder you are using. You may attach here to the forum in .zip format or you may send it to This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

4 years 3 months ago #29532090 by Arunya
Hi,
I am here sending you the link to encoder data sheet
www.zhengkemotor.com/product/product60.html





Encoder was mounted in the back side of motor, which having 1:45 gear ratio. Encoder is giving 500PPR and when it multiply by gear ratio should be give 22500 pulses and count value in counter should be 22500*4 which is 90000. I verified this count value by directly reading encoder from micro controller. It was giving me the correct count value.when try to use SDC2130 counter it gives faulty reading(like 1000, 3000, etc) which is not even close to 90000.

motor data sheet also attach with related picture.thank you
Attachments:

Please Log in or Create an account to join the conversation.

4 years 3 months ago #29532091 by blake
Hello again, thank you for providing the datasheet for your encoder. Our controllers can process up to 32000 ppr. However there is in fact an bug in Roborun+ that will not allow you to configure a ppr over 5000 from the Configuration tab as you had previously mentioned. To get around this you can can set your ppr manually from the script tab:

Send command ^EPPR cc nn, where cc is the encoder channel and nn is the ppr value.

Then save this new configuration setting to the controller by sending %eesav

This is detailed in our user manual on page 210 for your reference.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.244 seconds