Incorrect info regarding CAN connections

3 years 2 months ago #29533080 by Annem
I was trying to set a RoboCAN with 2 nodes. I was told to check out this article( link ). In the article, it says pins 8 and 20 in the 25pin port are set as CAN_L and CAN_H in roboteq devices. I read this and did the connections accordingly which is why i believe i couldn't detect the second node as the CAN_L and CAN_H are different in different roboteq devices. See the attached files for reference.

File Attachment:

File Name: can_problem.zip
File Size:500 KB
Attachments:

Please Log in or Create an account to join the conversation.

3 years 2 months ago #29533090 by blake
Hello Annem,

Do you have your controllers connected to your PC with USB at the same time as you are trying to use CAN? If so this is the issue. The model of controller you have is an older hardware revision. With this controller you cannot use USB and CAN at the same time. If you want to use CAN at the same time as your controller is connected to you PC, you will need to use an RS232 serial connection instead of USB.

Please Log in or Create an account to join the conversation.

3 years 2 months ago #29533092 by Annem
That is not the issue. I am using rs232 alone right now. But the issue i am talking about is the fact that in the article it says 8 and 20 pins in roboteq devices are CAN_L and CAN_H which is not the case. I looked at the HDC2450 datasheet and realized that the CAN connections are on the DB9 port.

Please Log in or Create an account to join the conversation.

3 years 2 months ago #29533094 by blake
You are correct, this is an error in the article, I apologize for the confusion. You will use pins 2 and 7 on the DB9 connector of your HDC2460. Thank you for bringing this to my attention, I will amend the article right away
The following user(s) said Thank You: Annem

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.178 seconds