SDC2160S - Controller working but the motor doesn't turn.

2 years 8 months ago #29533440 by constantine
Hello there!
The problem that I have is this: I want to cotrol a motor (24Vdc/20A). I have configured the controller to drive this motor. As an Input I am using an 0-5V. So, I have connected everything to the controller, the batteries, the motor, the Analog Input, and the motor still doesn't turn. I connect to the controller, I go to RUN in Roborun+, the controller is "seeing" the Input and reads the battery voltage etc BUT the motor still doesn't turn........ Any help?
Thanks in advance!!!

Please Log in or Create an account to join the conversation.

2 years 8 months ago - 2 years 8 months ago #29533441 by Gabriel_Isko
Make sure your priorities are set correctly in the configuration tab (Input/outputs>Commands> Command Priorities) They should be:

1) RS232
2) Analog
3) None

Command priorities are outlined on 154 of the User Manual .

You can also debug the actual commands sent to each channel using the Capture panel in the Run tab. You can set the channels to Motor Command for the commands being sent to the motors, and Motor Power for the actual output going out to the motors on the controller's motor leads.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.164 seconds