Servo test

15 years 8 months ago #3059107 by Darrell
Servo test was created by Darrell
I'd like to do an analog test from my wireless communication modual (totalrobots WCM) to the Roboteq. I want to use two pins from the WCM to the corresponding I/O lines on the Roboteq. Anything I need to be wary of while doing this? Is it a problem connecting directly into the serial port on the Roboteq with pin connectors? Thanks.
Darrell

Please Log in or Create an account to join the conversation.

15 years 8 months ago #3059278 by cosma
Replied by cosma on topic Re:Servo test
I am not familiar with the WCM but glancing over the datasheet nothing stands out.

Verify that the WCM's RS232 port can support 7 bit, even parity, 1 stop bit at 9600baud with no flow control.

When connecting the RS232 Tx and Rx pins, you will also need to provide power to the input opto coupler. This is done by wiring pin 6 to 13 and pin 7 to 14 of the AX2550's 15-pin connector.

I do not understand what you intend to do with the WCM's analog port. If it has an analog output and you intend to use it to drive the controller, this would work but keep in mind that it needs 2.5V to stop, 0V for full reverse, 5V for full forward.

Please Log in or Create an account to join the conversation.

15 years 8 months ago #3060620 by Darrell
Replied by Darrell on topic Re:Servo test

Thanks Cosma. I intend to use the RS232 for final control. This is just a quick test to see if the WCM is sending data and I didn't want to damage anything in the process.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.151 seconds