Communication via RS232 radio

14 years 6 days ago #12902275 by clehmann
Communication via RS232 radio was created by clehmann
<P style="MARGIN: 0px">We are using a pair of Phoenix RS232 data radios to communicate between a laptop and a AX2550. I can open Roborun and select the correct port and the utility will find the controller, but when I try to read the controller configuration it tells me that I should verify the COM port and check whether the controller has power. Both settings are correct and only moments ago were able to see the controller enough to show "Communcation Established" at the top of the utility. Furthermore, sometimes when I try to poll the configuration after a seemingly successful connection, I get a Error 401, something about non-modal mode, that when I click OK crashes the utility. I can hook up directly to the Roboteq and everything checks out perfectly, I'm just trying to add in the radio and am having these problems. Any thoughts?
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">Thanks!

Please Log in or Create an account to join the conversation.

14 years 21 hours ago #13015681 by RogueWarrior
Replied by RogueWarrior on topic Re:Communication via RS232 radio
That error in Roborun happens frequently to me especially when things aren't working as expected. If I've got the controller plugged into a COM port that isn't the default or isn't working, I'll see that.

Please Log in or Create an account to join the conversation.

14 years 20 hours ago #13016419 by cosma
Replied by cosma on topic Re:Communication via RS232 radio
<P style="MARGIN: 0px">To troubleshoot, it would be best to take Roborun out of the picture (which is known to produce these errors in some configurations)
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">Use instead hyperterm and verity that you get good and clear communication between your PC and the controller.
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">There is a supplied and already configured hyperterm session. Look for it at start&gt;Programs&gt;Roboteq&gt;roboteq-com1

Please Log in or Create an account to join the conversation.

12 years 2 months ago #27131207 by CAATman
Replied by CAATman on topic Re:Communication via RS232 radio
I was wondering if you ever overcame your wireless communication problem? I am running into exact problem with AX3500 using Parani SD-100 (Bluetooth). I gave up on Parani and am purchasing Maxstream radio modems to perform RS232 communication. Have any ideas?

Thanks,

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29207941 by cosma
Replied by cosma on topic Re:Communication via RS232 radio
We just conducted our own experiments witht he Parani adapter.

Using a simple test (without a controller) where there was one hyperterminal session on each PC:

HT on PC1-&gt;Com1-&gt;Parani ~~~btooth xmission ~~~ BT dongle-&gt; HT on PC2

we determined that 7bit + even parity transmission will not work.

Unless the manufacturer has a version of their firmware to support 7b+e, it will not work with our AX-family controllers, unfortunately.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.282 seconds