Position mode

13 years 11 months ago #13350636 by hemantdandekar
Position mode was created by hemantdandekar
<P style="MARGIN: 0px">We have commition the Roboteq for the position mode.
<P style="MARGIN: 0px">1.Reseted encoder counter and DR using !q2
<P style="MARGIN: 0px">2.Loaded mail box using *mm command
<P style="MARGIN: 0px">3. Loaded DR using !q7 and !q8
<P style="MARGIN: 0px">result=&gt; The motor stared oscillating back and forth.
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">In fact it is expected that the motor should have run in one direction until encoder counter reached DR. What must have gone wrong? The commanded position was 00 00 02 FF in hex.
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">In close loop speed mode speed we set using TABs in ROBORUN utility is exspected to be seen in ENC(Encoder) window or not? IS it that after tunning PID parameter the speed we set is same as seen in ENC window. or difference in two speed is error? We have observe that the error at lower speed is more as compared to that in higher speed.
<P style="MARGIN: 0px">How to give the command in position mode through Roborun utility? Gime the steps for the same.
<P style="MARGIN: 0px">

Please Log in or Create an account to join the conversation.

13 years 11 months ago #13376823 by cosma
Replied by cosma on topic Re:Position mode
<P style="MARGIN: 0px">See my other post on reaching destination without oscillation.
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">When excercising the closed loop modes with encoders, it is best to use the Encoder window of Roborun.
<P style="MARGIN: 0px">
<P style="MARGIN: 0px">In it you see all the relevant parameters: distance, speed, counter value. It is easier to see what's going on and to diagnose problems

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.119 seconds