SERIAL COMMUNICATION

11 years 11 months ago #29015033 by tkjol
SERIAL COMMUNICATION was created by tkjol
After numerous attempts, I successfully made communication between the AX500 and a PIC microcontroller. One of my first commands was to change Input Control just to see the LED's respond and verify that the command was recieved. Unfortunately, I put it into Analogue Mode and now I cannot get it to do anything. Even Roborun cannot establish communication.

Did I kill it? If not, how do I get it under control again? It was wired up for dual axis Closed Loop Position Control with the feed back potentiometers wired back to the AX500. Prior to my serial command, it operated great with Roborun. Please help.....................

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29022347 by cosma
Replied by cosma on topic Re:SERIAL COMMUNICATION
RS232 is still active while in Analog mode.

With Roborun, click on the Console tab and verify that you see the data loggin string after reset.

If you do, verify that senting 10 Enter keys will make it switch to RS232.

If the above fails, verify carefuly your rs232 wiring.

Try re-installing the firmware.

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29050679 by tkjol
Replied by tkjol on topic Re:SERIAL COMMUNICATION

Roborun cannot establish communication with the AX500. How do I re-install the firmware?

Please Log in or Create an account to join the conversation.

11 years 11 months ago #29051243 by cosma
Replied by cosma on topic Re:SERIAL COMMUNICATION
Turn off the controller. Launch roborun, click on "Update Firware". Power the controller on when prompted.

Note that this will wok aslong as the MCU on the controller is working and that there is no damage to the rs232 driver, and the connection to your PC is good.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.201 seconds