SDC 2150 Motor position mode velocity problem

8 years 10 months ago #29526281 by subzero787
Hi! I\'m having problems using the !S command in SDC 2150. I\'m sending a command of !S 2 200, I\'m expecting motor 2 to have a 200rpm speed, however no changes can be seen specifically on the closed loop parameters in roborun. FYI, my firmware ID is Roboteq v1.2 RCB100 12/11/2011 and I\'m running it on the closed loop position relative mode.

Thanks.

Please Log in or Create an account to join the conversation.

8 years 10 months ago #29526303 by Michael Burton
Change the speed for closed loop in the closed loop settings. The speed command only works in speed mode.

Please Log in or Create an account to join the conversation.

8 years 10 months ago #29526305 by subzero787
yes i am already in the closed loop position relative mode but it is still not working

Please Log in or Create an account to join the conversation.

8 years 10 months ago #29526307 by roboteq
See the demo video at
www.youtube.com/watch?v=xptBWoCq6Rc&feat...G260ffdcAUAAAAAAAAAA

What kind of position sensore are you using for feedback?

Please Log in or Create an account to join the conversation.

8 years 10 months ago #29526309 by Michael Burton
subzero787 wrote:

yes i am already in the closed loop position relative mode but it is still not working


The speed command only works in speed mode not position mode.

To change the speed in position mode you need to change the closed loop settings.

Please Log in or Create an account to join the conversation.

8 years 10 months ago #29526323 by subzero787
so is it correct for me to use ^MVEL instead of !S?

Please Log in or Create an account to join the conversation.

8 years 10 months ago #29526325 by Michael Burton
_MVEL

This sets the Motor(s) Default Position Velocity and should be correct for closed loop position mode.

SetConfig(_MVEL, Motor#, speed)

Please Log in or Create an account to join the conversation.

8 years 9 months ago #29526891 by subzero787
do i need to send a %EESAV for the mvel to have an effect? if so, is there another way i can do this without having to?

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.238 seconds