SBL1360 analog input range changed

7 years 2 months ago #29528210 by Herman
I have a SBL1360.

What I see that an analog input on pin10 (ANA5) displays in Roborun not the absolute input voltage:

input >> Aln5 display
0V = 0
2.5V = 1800
5V = 3600

Another controller (MBL) displays the input voltage as absolute voltage like 5V displays 5000

Please help.

Herman

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528211 by roboteq
Replied by roboteq on topic Re:SBL1360 analog input range changed
If this is happening only to one channel and if you have double checked the wiring, then it may be a problem with the calibration values.


From the console send ~zaic

Report the values returned

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528212 by Herman
Wiring is ok, use same setup with MBL1650.

calibration values normal

250mV - 2500mV - 4750mV

send ~ziac from console: return 0:2:1:2:2:2:-2

Analog input 1 and 2 checked: normal behaviour

If I enable all analog inputs I see that Aln5 and Aln6 exactly display the same value with only analog input 5 connected.

Short on uC ?


Herman

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528213 by roboteq
Replied by roboteq on topic Re:SBL1360 analog input range changed
try connecting only analog 5. If the value is the same on analog 5 and 6, that would point to a shorting problem

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528214 by Herman
Hi Cosma, I did (....with only analog input 5 connected)

Herman

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528215 by roboteq
Replied by roboteq on topic Re:SBL1360 analog input range changed
Please clarify. Do you see the same problem when connecting to ain5?

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528216 by Herman
Input impedances AIN/DIN to Ground, controller off:

input
1 53K
2 53K
3 53K
4 53K
5 36K !!
6 36K !!

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528217 by roboteq
Replied by roboteq on topic Re:SBL1360 analog input range changed
There must be a short. Try locating it, if possible.

AIN5 goes from pin10 of the connector to R33. The other end of R33 goes to R42

AIN6 goes from pin 15 to R38. The to R43.

Send a high resolution photo of the showing the 15pin connector and the resistors that surround it.

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528218 by Herman
On my board R38 goes to R46 (not R43)

I cannot see any visible short at the top of the PCB. I measure a short between the hot sides of R46 and R42. The hot sides are the sides who are connected to R38 and R33. The other sides of R46 and R42 are GND.

Also R38/R46 and R33/R42 having a considerable distance from each other so a short there is not possible.

I see there are via\'s in the board but how can I have a look at the backside of the PCB ?

Are the inputs via the resistor divider conncted to the ARM. Maybe there is a short between the pins on the ARM or is that not possible. If you give me the pin# I can have a look.

Addition:
See possible shortage on ARM pins near R54. I cannot see it clearly with my magnifying glass. Are inputs 5/6 connected on that side near R54 ??

Please Log in or Create an account to join the conversation.

7 years 2 months ago #29528219 by roboteq
Replied by roboteq on topic Re:SBL1360 analog input range changed
The mcu pins are 61 ans 52. They are near C5.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.248 seconds