SDC 2160 + PC utility : How to see Hall sensor A and B value in channel

6 years 6 months ago #29528961 by Maxime
Hi,

I'm using a SBC2160 with a Emg30 Devantech 12V, 30:1 GEAR Motor w/Encoder.

I connected a DC alimentation in 12V on Vmot and GND pins, and on 15 pins connector :

on pin 4 EncA, 8 EncB, 14 vcc, 13 GND and RS232 on 2,3,5 pins.

When i use the pc utility, the application detected the SDC2160 and i used the slider to turn on the motor.

All worked fine, but i can't see HAll sensor values in channel or in the application. It seems that the application didn't used the hall sensor.

What can i do, to have an encoder feedback ?

Thanks.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528963 by Griffin Baker
Completely disable the pulse inputs 1 and 2. Make sure to uncheck the check boxes next to them.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528965 by Maxime
Thank you,

i tested but nothing change.

a screenshot of configuration Pulse Inputs and Encoder 1 :




i saw in a vidéo , that is possible to show, during running, hall sensor A and B value in channel choice but i don't have this value.
Attachments:

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528966 by Griffin Baker
Try setting up the encoder for feedback 1 only.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528967 by Maxime
I made a screenshot of the video, and put in red the type of informations that i would like to Watch.




How can i see it?

Thanks

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528968 by Griffin Baker
In the run tab of the Roborun+ utility will toggle the respective digital inputs that are shared on those lines. Also in Open loop mode, feedback does not do anything. You must be in a closed loop mode.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528969 by Maxime

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528970 by Griffin Baker
Upload it in a zipped folder.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528971 by Maxime

Please Log in or Create an account to join the conversation.

6 years 6 months ago #29528972 by Maxime
I can change the operating Mode in motor 1 OutPut but i have 4 choices in closed loop mode (Speed, Position relative, Count Position, Position tracking.)

I unchecked the digital inputs and outputs in Run view.

it change nothing.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.185 seconds