Trouble Connecting to ax2550 controller with Roborun configuration software?

6 years 3 weeks ago #29529556 by Griffin Baker
If you look at the controllers LED, does it have a flashing pattern, or a solid 8 with a dot next to it?

"noctrl" or "8.".

Sometimes, the communication won't come up if there is a "8." as it means the controller is defective and needs to be repaired.

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529557 by Lewis
I'm using the controller as part of an autonomous vehicle system that my boss bought from some company, so the actual controller is within a casing that I'm not sure if I can remove (that's why I'm trying to configure it using Roborun). However, I'm pretty sure the controller is functioning because I am able to drive the vehicle remotely using a demo that came with the system.

If you still think it could read 8 or noctrl though I will attempt to remove the casing to check.

Thanks

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529558 by Griffin Baker
Well if it is running autonomously, it would have to be set so it isn't running. Likely you have a couple of choices, but whatever came with the controller in terms of configuration may not be recovered depending on the route you go.

You can do a manual reset to default configuration of the controller using the push buttons. Refer to the user manual for that. When you do this, all settings will revert to factory defaults. Previous configuration is permanently lost.

The other option, is to disconnect everything and power on only through the power control and connect via the RS232. You can save the configuration profile in the event you want to reuse it later down the road. Simply read back the configurations from the controller and click save profile to disk.

You'll know when the controller is reading the RS232 because the top of the browser will start to populate information.

If everything is working currently except the RS232, then it is unlikely that there will be a "8." on the led display.

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529559 by Lewis
Here is said screenshot. I am connecting it with a serial->usb cable actually (although it also doesn't work connected directly into the serial port (although I'm not certain which com port to select in that case, I'm using com1))

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529560 by Lewis
sorry not sure if you got the last screenshot. Here it is again

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529561 by Griffin Baker
Mine comes in as com3. Therefore it shows up in Roborun as com3 active. My port is set to com3 in Roborun as you saw earlier.

When the controller is powered up, then it will say com3 open and the info will populate and it will then ask if I want to read back from the controller settings.


Attachments:

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529562 by Griffin Baker

Lewis wrote: sorry not sure if you got the last screenshot. Here it is again

When you upload a file unless it is a zip, click on the the insert button next to the add file.

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529565 by Lewis
here you go:



And I am connecting it with a serial to usb caable (although I've tried it directly alson without success (although I'm not certsin which port to use in this case; I'm using com 1 here)).

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago #29529566 by Lewis

Please Log in or Create an account to join the conversation.

6 years 3 weeks ago - 6 years 3 weeks ago #29529567 by Griffin Baker
When you installed the software, did you get an error about an OCX file? You needed the strip.OCX file installed to get the software working right with windows 7.


You place that in your C:/ Directory. For some reason it just goes there with your program files and program files(X86) folders.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.184 seconds