Couldn't control speed in closed loop speed mode

5 years 4 months ago #29530624 by nouf
Hello,

I'm using SDC2130 MC.
And I need to control the motors speed
I used setCommand(_GO, 1, SPEED) and the motors move in a fixed speed (between 18 and 19.5) whatever SPEED value was.
Also, I tried the slider in the utility but there is no effect, once the command is sent the motors keep moving in the fixed speed, but change in direction if the slider moves to the negative side. I can't even stop the motors.

Can someone help me?

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530625 by TechSupport
What are you using for feedback? If you aren't using anything, then it won't work properly.

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530626 by maha

TechSupport wrote: What are you using for feedback? If you aren't using anything, then it won't work properly.


I'm using encoders

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530627 by TechSupport
In your encoders section, make sure that your encoders are set up as feedback, select the correct PPR, and the checkbox to the right of "Input use" for the motor it will be used for.

First thing to do. Set controller back to open loop mode.

In the Pulse inputs section, disable completely the pulse inputs 1 and 2 as they share the same lines as the encoder.
Conversion type: none
Input use: disabled - uncheck checkbox next to it.

Save to controller.

In the run tab, select a channel in the bottom right corner, and select: counter 1 and counter 2 (if used). Use the slider and make it go forward - count should increment positive values, and the reverse will be negative count.

If all is good there, then select you closed loop mode.

Start with P = 0, I = 2, D = 0

Set loop error detection to disabled.

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530628 by nouf

TechSupport wrote: In your encoders section, make sure that your encoders are set up as feedback, select the correct PPR, and the checkbox to the right of "Input use" for the motor it will be used for.

First thing to do. Set controller back to open loop mode.

In the Pulse inputs section, disable completely the pulse inputs 1 and 2 as they share the same lines as the encoder.
Conversion type: none
Input use: disabled - uncheck checkbox next to it.

Save to controller.

In the run tab, select a channel in the bottom right corner, and select: counter 1 and counter 2 (if used). Use the slider and make it go forward - count should increment positive values, and the reverse will be negative count.

If all is good there, then select you closed loop mode.

Start with P = 0, I = 2, D = 0

Set loop error detection to disabled.


I did exactly as you said regarding open loop and everything works as expected. When I got back to close loop speed it produce the same progress

Please Log in or Create an account to join the conversation.

5 years 4 months ago #29530631 by TechSupport
I've attached 2 different firmware files. Please try the latest one first, and if that doesn't solve it, try the older one.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.154 seconds