Control Help XDC2230

6 years 9 months ago #29532232 by roamingrobots
Afternoon everyone,

I think I'm doing something stupid here.

Fitted an XDC2330 controller into a robot this morning, plugged it into roborun to set up the mixing all fine, checked the operation via the laptop all good.


When I unplugged everything and went to test it, it has no control via RC. The receiver was powered and I plugged a servo to test this and all worked fine. Went back into roborun and checked everything and this time left the rc connected and I got control of it on both robo run and the rc.

The only way I can get control RC of it is to plug it into roborun, then exit and it has control. Its as if the controller isn't picking up the receiver although the receiver is getting power.

Ive tried alsorts, first of all, different TX, then different RX, then different Rs322 lead, but nothing changes it. Ive tried chaingng the input priority in the controller but nothing makes it work apart from starting the controller in Robo Run amd then unplugging it, and then it works fine.

But as soon as I remove and replace power it is still waiting for a signal.

Any help greatfully received.

Please Log in or Create an account to join the conversation.

6 years 9 months ago #29532234 by blake
Replied by blake on topic Control Help XDC2230
Just for clarification, is the problem you are experiencing that the motor controller is not accepting RC control at all, or is it that it only accepts RC control when the controller is connected to your PC?

Which version of firmware is currently on your motor conroller?
What RC receiver are you using (make and model)?
Please attach the configuration file you've been using here in .zip format. If more comfortable you may instead send it to This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.074 seconds