FBL2360 and Resolver Configuration

3 years 5 months ago #29532816 by AZP_OKIRND
I am trying to get an FBL2360 to control a motor, which is monitored with a resolver. The resolver outputs the expected output when tested with an oscilloscope. I am having trouble configuring the RoboteQ device using RoboRun.
Does anyone know how to configure the RoboteQ to use output from a resolver (sin/cos) as feedback?
Any help will be greatly appreciated.

Best regards.

Please Log in or Create an account to join the conversation.

3 years 5 months ago #29532817 by blake
The current hardware revision of the FBL2360 is not equipped to accept Resolver feedback. This will be available in the next hardware revision of our FBL2360 which will be released to US customers within the next 4-6 weeks and to the rest of the world shortly after that.

Please Log in or Create an account to join the conversation.

3 years 4 months ago #29532845 by AZP_OKIRND
Hi @blake

As per your response, I understood I could not use Resolver inputs. Therefore, I am using Sensorless switching mode now. In sensorless settings, I gave Startup power' 700 (70%) and Startup Timer Ticks: 20000 (although I still don't know how this Startup timer ticks works). I am attaching my configuration screenshots.
Problem is my motor is not moving with the speed which I am expecting. Its slow. Currently the motor is attached to the steering wheel shaft. Therefore, steering wheel is not rotating properly and stucking when I am going to -700~-1000 to +700~1000 motor command. Its slow and vibrating.
I increased the Vmot voltage to 48V and speed little increased but still not enough.
My question is why my speed is affecting when I am using sensorless switching mode option? Any help would be highly appreciated.

Regards
Attachments:

Please Log in or Create an account to join the conversation.

3 years 4 months ago #29532852 by blake
Did you just set the SSP and SST at random or did you perform the calibration? If the calibration wasn't performed please follow the steps as detailed on page 98 of our user manual. This will be done from the Console Tab of Roborun+, you will first need to disable the Serial Watchdog by sending the comand ^RWD 0

Please Log in or Create an account to join the conversation.

3 years 4 months ago #29532854 by AZP_OKIRND
I tried calibrating but still no change. Let me write down the process:

1) I set all the default values like SSP: 75 and SST: 65535 and changed Switching Mode to SENSORLESS.
2) Now went to Console tab and wrote ^RWD 0 and click send.
3) Then wrote %clmod 4 and click Send
4) Then I went to Run tab and gave motor command: 10 and then -10 but the steering wheel (which attached to the motor) is not even moving. Although I can see my hall speed RPM is moving up to 300~400 when motor command is positive and -300~-400 when negative motor command.
5) I have no idea whether the approach is right here.
6) I then wrote %clmod 0 and clicked Send.
7) Finally wrote %eesav and clicked Send

Is the right procedures? Please let me know.
Regards

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.343 seconds