SDC3260: Count Position Mode Stops Working After Hitting Limit

4 years 5 months ago - 4 years 5 months ago #29534633 by stephen.ritter
To give background into the issue I am facing, I have 2 linear actuators hooked up to the SDC3260 each with quadrature encoders and are connected on motor 1 and 2. Each actuator has a forward and reverse limit switch which are hooked up into the digital inputs to limit the length each actuator can extend to. I use a homing routine that puts the motors in open loop mode and commands them in reverse until the reverse limit switch is high. I then put them into closed loop count position mode and command them to go to position 0 with setcommand(_P,1,0), and setcommand(_P,2,0). This works as expected. The problem arises and I can easily test this through the Roboteq Motor Control Utility, when I attempt to command the actuator past the limit switch. If I command motor 1 with !P 1 1000 the linear actuator will start extending until it hits the forward limit switch which is around position 560 and stops which is to be expected. Then if I command motor 1 back with !P 1 0 the actuator will not move and is stuck in that position until I run my homing routine again. This also happens with the relative position command !PR as well. I should say that if I command motor 1 with !P 1 250 the actuator extends and stops around position 250, and I am able to send it to another position forward or reverse. In the end I would like to use the relative position command to control the actuators, but neither of these are working if it is commanded past the limit switch and that can be dangerous if an actuator gets stuck at a fully extended or fully retracted state. In the Roboteq Controllers User Manual it states that the following:

New position destination command can be issued at any time. If the previous destination is not reached while the new is sent, the motor will move to the new destination. If this causes a change of direction, the motor will do the change using the current acceleration and deceleration settings.

I also noticed that when using the Roboteq Motor Control Utility I was able to get it to move when it is stuck by switching to the scripting tab after I commanded it past the limit, and going back to the console tab and command it to another position. It had to be the scripting tab. None of the other tabs would get it unstuck which implies that a command that I am unsure of is called which clears this error. I was wondering if I there is way to force it to go to a new command that I missed, or if there is a work around to this?

Please Log in or Create an account to join the conversation.

4 years 5 months ago #29534634 by stephen.ritter
Here is the attached log file when I was running these tests. I was having trouble attaching a txt, but it worked with zip.

File Attachment:

File Name:
File Size:2 KB

Please Log in or Create an account to join the conversation.

4 years 5 months ago #29534635 by stephen.ritter
As an update through more testing I am able to get it unstuck by calling !EX and !MG, however this is not really a fix.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.064 seconds