MDC2460 energize both servos with RS232

6 months 2 weeks ago #29535315 by tedzini
Greetings,I have an interesting issue that I'm stuck with the MDC2460, FW=2.0a.Initially, the RS232 based speed commands worked fine but the PWM inputs were not responsive. I then enabled 4 of 6 PWM inputs for that. And now the RC Futaba stick works fine, but then the changes broke the RS232 control.

With Roborun+  plugged either into the UART 232 port, or the USB port, if I now enter:

"!S 1 125"  or
"!S 2 125" , or even chaining them together as in:
"!S 1 125_!S 2 125"

Only the #1 servo spins, while #2 never spins. I even tried disabling the PWM inputs again, or only enabling just RS232 as
a single priority, as well as trying open loop speed vs. closed loop speed. The RS232 watchdog value also did not affect this
behavior.

Would anyone have any insights what the issue might be? Why would enabling the PWM input 'break' the RS232 mode?
What might be interrupting the action of energizing the second servo? Before I 'blindly' change/reinstall FW, I want to
understand what is going on.

thanks very much in advance for any help,
-t

 
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.064 seconds