Multiple issues with SDC2160

7 months 1 week ago - 7 months 1 week ago #29535586 by maple
We have SDC2160 driving two linear actuators. The pots are connected to analog inputs 3 and 4. I've used Open Loop mode to test motors and calibrate analog ranges.
Then I switched first motor to Tracking Position mode and was able to achieve smooth and precise positioning with P:6, I:0.5, D:0.3. I have copied all settings to motor 2 and tried second actuator. It did not work.
Problem 1:
Analog input 4 is not working as Feedback 2. I can see input changing as expected on Run screen, but the feedback in a log remains at 0. The configuration ~AINA returns 0,0,18,34,0,0 which means inputs 3 and 4 should be used as feedbacks for motors 1 and 2.

So, I thought there is something wrong with this controller and tried another one. To save time I stored profile on disk, connected to new controller, loaded profile and tried to save it to controller.
Problem 2:
Cannot download profile to controller. Immediately after download the controller resets, RoboRun loses connection, offers to load profile from device. After this all settings are back to their default values. This worked without problem on the first controller, and they both are from same batch and have same v1.8 firmware version. At this point I decided to update firmware to v2.1. After the update I was able to read and download profile to device. The problem 2 solved and I tried running first actuator.

Problems 3 and 4:
Immediately it started awful rattle, which was getting even noisier when close to target position. The motor power log showed wild oscillation with about 80% swing. Setting D gain to 0 finally stopped the rattle. Luckily, the motors still worked. However positioning was abysmal. With the same P and I as it worked before the positioning was slow and imprecise, often stopping with 60-70 loop error, then slowly creeping to the target. No matter how I changed gains I wasn't able to achieve acceptable tracking.

I though to try changing PID settings via script. I noticed that there are now 8 different gains in configuration, instead of 3 in the old firmware. The settings for non-torque modes are split into groups for Speed and Position.
Problem 5:
There are only 3 commands available for scripting, KPG, KIG and KDG. These seem to change Position gains only. There are no commands for Speed gains.

Oh, and problem 1 is still there in v2.1 firmware - I cannot use analog input 4 as position feedback for motor 2. Is there any way to solve these problems or should we look for a different supplier?

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.085 seconds