Safety Stop (SFT) command not working

3 months 2 weeks ago - 3 months 2 weeks ago #29536132 by hansstols
I am using a v2.1-GBL2660T to control an autonomous vehicle using closed loop speed control on two wheels.

I have a safety bumper on the vehicle, and when it is triggered, I need to stop the vehicle as fast as possible. My normal deceleration rate is 4500 RPM/sec. But for this safety stop I want to decelerate faster. I tried to use the Safety Stop (SFT) command, but it does not seem to have any effect at all.

I tried sending the "!SFT 1" and "!SFT 2" commands and the "!SFT 1_!SFT 2" commands combined from the Roborun+ utility.

Edit:
If I mute the command to force a timeout, the motors do slow down with the fault deceleration rate. But the safety stop flag is not set in the fault flags (FF).

With the SFT command, either with or without setting the commanded speed to 0, I do not get the motors to slow down with the fault deceleration rate. Also the safety stop flags are not set for the motors. I do see a '+' acknowledgment from the controller. So the command is properly received, but it is as if the command is not processed at all, other then the acknowledgment that is sent.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.073 seconds