Menu

Topic-icon Losing USB connection to SDC 2130

More
8 years 2 months ago #29526153 by edparker
Originally we could not get our SDC2130 motor controller to work in closed loop (speed or position). After downloading the latest firmware it seems to be working just fine. However, the USB connection to our PC, running the Configuration Utility, loses connection every few minutes. Does not seem to be noise related and it never happened with the firmware that originally shipped with the controller. Any Ideas what could be causing the \"Controller Lost\" events?

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
8 years 2 months ago #29526155 by roboteq
Replied by roboteq on topic Losing USB connection to SDC 2130
We will look into this and send you firmware to test.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #29526157 by edparker
OK, Thank you.
Standing by...

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
8 years 1 month ago #29526167 by roboteq
Replied by roboteq on topic Losing USB connection to SDC 2130
Pls try the attached and report.

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
8 years 1 month ago #29526169 by roboteq
Replied by roboteq on topic Losing USB connection to SDC 2130
file attached

Attachment SDC21x0_Firmware_Update_v12_121111_dfu.zip not found

Attachments:

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #29526173 by edparker
Moderator,
Thanks, I downloaded the firmware file: SDC21x0_Firmware_Update_v12_121111.dfu and installed it in my SDC 2130. I did get a USB disconnect one time after 5 min, however it has been running now for over two hours without a \"Controller Lost\" dialog. I am hopeful that the problem is solved. In my application I only need the USB connection for Configuration, so this is workable. I will continue to test the reliability of the USB interface and report if there are new occurrences.
Ed

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #29526263 by pahan
I\'m also seeing this issue, and I\'ve tried the new firmware, it seems to happen less often, but still about every minute. I\'m trying to use the SDC 2130 with 2 encoders.

Please Log in or Create an account to join the conversation.

More
8 years 1 week ago #29526405 by mbalazs
I am having this issues as well with the latest firmware but using the c++ code rather than roborun.

1) What I see is that it open the connection fine.

2) Accepts a random number of commands before a transmit fail message comes back (RQ_ERR_TRANSMIT_FAILED)

3) After this it won\'t take any more commands until the handle is closed and reopened.

4) However, this doesn\'t always work.. when it doesn\'t, it connects but the response on the version check is empty (with status RQ_INVALID_RESPONSE) which leads to a RQ_UNRECOGNIZED_DEVICE.

Leaving it idle will sometimes resolve this issue as well.

Any help would be greatly appreciated.

Michael

Please Log in or Create an account to join the conversation.

More
8 years 1 week ago #29526409 by edparker
Since I am the original reporter on this thread I feel that an update from me might be useful. I am still experiencing connection losses as well. The firmware update helped reduce the frequency of dropped connections, but only in the sense that sometimes connection is maintained longer, up to 10 minutes or so. But eventually it is always lost. On a random basis, the controller is lost as quickly as one minute. I have not been able to determine any condition that correlates to the dropped connections.

I am curious about this problem in any of the other Next Gen controllers because I am starting a project using the HBL2350.

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
8 years 1 week ago #29526413 by roboteq
Replied by roboteq on topic Losing USB connection to SDC 2130
\"unfortunately\" we have not been able to observe such a high frequency of communication loss, which makes the problem particularly difficult to trace. What we typically see is controllers running for hours eventlessly. We seem to have found that a longer cable does increase the odds of connection loss.

Let us know how the HBL2350 performs as this will give us additional clues.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.140 seconds
Go to top