Menu

Topic-icon MGS1600C - Single line position mensurment error.

More
4 years 11 months ago - 4 years 11 months ago #29529975 by Marcin.A
Hi,


I use MGS1600C in my mobile robot prototype with 50mm magnetic tape. I made firmware update and calibration and sensor works almost properly but i have problem with reading value near to the limits, depending on selected fork.

I made some tests with single, straight line without forks:

- When line is centered to the sensor position readed from left and rigth is almost correct and equal to center value 50%.
- When line goes to right side or angle is less than 90 degrees only the right tape signal is proper (it decreases proportionally to the growth offset of tape until the moment when tape is out of range). Left signal near to the center is correct but when offset of magnetic tape growth to the right side, left signal decreases slower than right and if it achive about 30% value it start to increase proportionally until the tape is out of range (it has value about 45%).
- When line goes to left side situation is similar - Left signal is correct, it increases proportionaly to the growth of tape offset in left direction. Right signal increases slower and near 70% it start decrease to about 55% near out of range limit.

Do you have any idea how to solve this problem? Is this typical for this sensors? I tried to read data from MGS through serial port, PWM and Analog output and results were the same. I use mgs as main position sensor in differential drive robot. Track of robot has turns and forks and its important to recognize fork or turn on way.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #29529987 by TechSupport
Have you tried recalibrating the sensor back to zero using the mag sensor utility?

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #29529996 by Marcin.A
Yes, I made calibration from mag utility several times and I updated firmware to the newest version. Could you check that is possible to get equal signals from left and right tape signal on single line in full sensor range?

Please Log in or Create an account to join the conversation.

  • roboteq
  • roboteq's Avatar
4 years 11 months ago #29530004 by roboteq
First you need to make sure that you selected the correct tape width in the configuration. For tape height, use 20 or 30mm as these settings work best even at higher height.

If the setting is optimal, then the left and right track should be very close to each other (within ~2mm) when hovering over a single tape.

The sensor will measure quite accurately as long as the tape is near the center. At the edges, the measured value is not going to be very reliable. This is because at the edge, the bell curve of the magnetic field is partial, and the sensor will estimate the tape position based on only one side of the curve.

In normal operation, this is not a problem because the final objective is to move the vehicle so that the tape is exactly at the center of the sensor.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #29530005 by Marcin.A
Thank you for your tips. I will try to set proper height of sensor and check the results.
The following user(s) said Thank You: kapa

Please Log in or Create an account to join the conversation.

More
4 years 9 months ago #29530322 by kapa
Hello, I'm also developing a, AGV with contolador HDC2450 and MGS1600C and also have the same problem, i update the firmware and also calibrate the sensor, and also tested other sensor, because we have two available and the results are the same, the test we made with magnetic tape already installed, and the tape have the size of 50mm, have to use your tape? or as is said on the site the sensor is compatible with tape from other suppliers.
Do you have any suggestions to resolve this problem.

Thanks M.Ferreira

Please Log in or Create an account to join the conversation.

More
4 years 8 months ago #29530324 by TechSupport
There are some other parameters you may want to check.

Magnet sensitivity
Tape size: 25mm, 50mm ' Default 25mm
Polarity, should be north bottom/ south top

In terms of the tape, they are polarized on each end. One side is south, the other side is north.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.119 seconds
Go to top