Menu

Topic-icon motor sings after firmware upgrade

More
3 years 5 months ago #29532116 by mrosenfield
I have several MDC2230 controllers running NPC 1200 motors in closed loop position tracking mode, controlled by RC pulses.
Have been running firmware 1.5. Just loaded firmware 1.6, and reloaded the parameters and script.
Now I notice the motor making an intermittent high frequency noise that it didn't make before.
The noise isn't a problem, per se, but I'd like to figure out what has changed and verify no issues.
Seems to operate as before the upgrade.

Thank you.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #29532120 by blake
Have you made a change to the PWM Frequency in your configuration? If so to what frequency? I tested an MDC2230 with firm v1.6 using my own motor and under default PWM frequency (18kHz) I did not experience any noise.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #29532121 by mrosenfield
No, I'm using the default frequency, and I am using all the same settings as before the firmware upgrade.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #29532124 by blake
Please send me your configuration file along with the script you are running at This email address is being protected from spambots. You need JavaScript enabled to view it. so that I can take a look

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.166 seconds
Go to top