Menu

Topic-icon Encoder 1 problems on a SDC2130 new hardware version

More
3 years 2 months ago #29532421 by metRo_
Hi all,

we have ordered 17 SDC1230 from robotshop to assembly our robot during the following days however we are having problems with encoder 1 as it doesn't work.

The setup where we tested the driver is the same that runs for some months with a older hardware revision of SDC2130.

We have tried 2 of the new SDC2130 both with problems on the Encoder 1.

Old SDC2130 revision: SD26 REV 15 1515 S/N F00923
New SDC2130 revison: SD26 V2.1 1626 I-00628

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #29532423 by Martinkim
I'm having same problem with FBL2360, it may be a same issue and I'm waiting for an answer.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #29532429 by blake
Please make sure you have the latest version of firmware that is available on our website (SDC21XX Firmware v1.6 4/14/16).

Additionally with the new hardware revisions of SDC you need to make sure to disable Pulse Inputs 1 & 2. These share the same input pins as Encoder 1, so if pulse inputs 1 & 2 are enabled then ENC1 will not work.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #29532430 by metRo_

blake wrote: Please make sure you have the latest version of firmware that is available on our website (SDC21XX Firmware v1.6 4/14/16).

Additionally with the new hardware revisions of SDC you need to make sure to disable Pulse Inputs 1 & 2. These share the same input pins as Encoder 1, so if pulse inputs 1 & 2 are enabled then ENC1 will not work.


Where should I disable it?

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #29532431 by blake
You can disable these from the Run tab of Roborun+:

Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #29532432 by Martinkim
Roboteq Motor Control Utility Configuration Tab, under Pulse Input, Click Pulse Pin 1&2, Click Capture Type, Select "Disabled", and save

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #29532433 by Martinkim
Blake,

Can you help my FBL2360 Encoder1 not working issue please? I'm having same issue.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #29532435 by metRo_

blake wrote: You can disable these from the Run tab of Roborun+:


It is working now! :)

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.967 seconds
Go to top