Menu

Topic-icon Cross talk between different motor channels

More
1 year 5 months ago #29533512 by davidezilio
Hi
I am using 2 RoboteQ SDC2130 motor controllers.
Each one is attached to 2 different motors.

I tried running the motors by
- sending serial commands with Roborun+
- through an Arduino script

In both scenarios I have the following erroneous behaviour:
The commands sent to the first motor being exercised are executed correctly.
After that, the commands sent to the second motor are not executed correctly and both motors start to spin as if there was some cross talk or queuing issues.
I have added delays but this did not solve the issues.
I am attaching the Arduino script for reference
Thanks in advance
Davide
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #29533515 by Gabriel_Isko
Do you think you can post your configuration? It sounds like the motors are behaving in mixed steering mode.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #29533517 by davidezilio
I found the solution thanks to this
www.roboteq.com/index.php/forum/14-gener...28838-sdc2130-issues
In practice I had to disable the watchdog.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #29533518 by Gabriel_Isko
Okay, glad to hear you found the issue.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.092 seconds
Go to top