Menu

Topic-icon HDC2460S Short Fault (reverse only)

More
3 weeks 1 day ago - 3 weeks 1 day ago #29534960 by ed_g
I've read some other forum messages that suggest this is a motor controller output stage fault but would like to confirm.

The motor controller is wired as one of a pair and as per the datasheet with a pre-charge resistor. The other controller is working just fine, and this one is when running forwards only - as soon as reverse is attempted the drive stops and the "short" fault is displayed (when using RoboRun).

I'll disconnect the controller and check for Vmot or 0V to output shorts but given the symptoms I'm pretty sure this is the cause. This is the first time the controller has been used (only arrived about 6 weeks ago) so I'm hoping it's a quick replacement job rather than a factory repair?

Alternately it could be a firmware issue? Seems unlikely as it affects one and not the other?

Anyway, will measure the outputs and add to this post.

Ok, there are no shorts to either rail, and an additional diode check on both sides looks the same on the faulty and the good controller.
The firmware (on both) is v1.8d HDC2XXX 1/18/2018 which appears to be latest (what is NORCB - there is a later version of this on the website?)

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #29534964 by ed_g
In case this affects anyone else, Roboteq sent me an updated version of the firmware which appears to have resolved the issue (HDC24XXS_NORCB-Firmware-Update-v18e-121019)

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.150 seconds
Go to top