Menu

Topic-icon RoboAGVSim dual direction robot settings - BUG or am I missing something?

More
2 months 2 weeks ago #29534691 by asyraf9
Hello,

I was playing around with the RoboAGVSim, and i was programming my robot to use both the front and rear sensors on the AGV.

In order to reverse direction i tried:

1) reverse the direction of the motors via setconfig(_MDIR, 1, 0) etc. This didnt work in the simulator. the AGV continues to go forward using the what is set as forward in the simulators AGV

2) i then programmatically reversed the motors via setting throttle to negative. This works, and may seem to be a good way moving forward.

HOWEVER, when i programmatically set the throttle to negative, and switched my sensor reading to the rear sensors - I found that the rear sensor seems inverted. left markers are detected as right (and vice versa) and turns (magnetic tape readings) are also flipped. it's as if you put both front and rear sensors facing forward - which doesnt make sense to me. no dual direction AGV will be installed with magsensors facing forward only.

it seems changing the profile settings (in my case _MDIR and flipping pulse input for magsensor2 capture polarity to inverted) don't do much. Am i missing something here? please help. thank you!

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #29534694 by blake
Thank you for your valuable feedback.

The _MDIR configuration is not currently implemented in the Simulator. However, thanks to your feedback we are working on implementing it now in addition to the suggestion of reversing the rear sensor. We will let you know as soon as the new revision is available.

Please Log in or Create an account to join the conversation.

More
2 months 6 days ago #29534706 by asyraf9
That's great news! thanks.

Sorry for the late reply. long holiday.

I really appreciate RoboAGVSim. Lets us save time, develop and test out our programming before putting it in the actual machine. thanks a lot for this.

Is there anyway I can contribute more to the development of RoboAGVSim?

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #29534719 by itrontik
Hello,

I also have same/simillar query.
I am using differntial drive configuration for the vehicle and wants it to run in both directions. n Roboteq AGV Simulation sample codes/simulation software, I did not find how to do it.

I tried to do it programmatically by two modifications: 1. reversing the throttle value (by reversing the sign) and 2. by reversing the MarkerLeft and MarkerRight.
However, still the problem remains, that the TapePosition which decides the amount of steering, is read from the rear magnetic sensor. Therefore, the robot steers only when the rear magnetic sensor reaches the marker (which is very late and most of the times the robot is already out of path). I have attached a snap after I tried to reverse it programmatically.

How can I solve this? Is it only simulation software problem or this will happen also in practice? I want to have a bidirectional robot and plan was to use the drive motors in the middle and two magnetic sensors, one at front and another at the back. And depending on the direction, it needs to take the respective magnetic sensor's input to steer. Kindly let me know If I am doing something wrong or if there is any other solution available? Or any other way to make it bi-directional (with same behaviour on either side).


Thanks,
Sharad
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.196 seconds
Go to top