Menu

Topic-icon Pin Assignment for SBL1360

More
4 years 4 months ago #29531225 by rajeshwar
The pin assignment of SBL1360 differs in different documents. I have downloaded the datasheet in which it says that pin 4 and pin 8 of DB-15 connector is for Encoder while when I checked on the 'Pin Details' in application software (Roborun+ Ver 1.4)it says Pin 10 and Pin 15 is for encoder. In the both the cases, the value of Enc Count is not changing in application software when the motor is running.

In First Case, when I have connected my Encoder to Pin 4 and Pin 8, DIN1 and DIN2 were blinking while motor is rotating, while in second case DIN5 and DIN6 were blinking.

I have disabled all the RC inputs and enabled the Encoder as Feedback.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #29531226 by TechSupport
The pinout in Roborun is outdated and hasn't been changed to reflect the new pinouts. The datasheet is the correct document to look at for pinouts.

4 and 8 are correct.

Edit: The latest version of Roborun has the correct pinout assignment. Please update the utility.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #29531229 by rajeshwar
Thanks. The pin assignment is actually 4 and 8 only.

In the latest version, the option 'JOIN' is not visible. Has it been disabled in the new version?

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #29531230 by TechSupport
There isn't a reason for there to be one if it is single channel only. The join was there for the purpose of a dual channel controller to drive both motors syncronously together.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #29531235 by rajeshwar
Of Course it is required for more than one channel motor controllers. I have tried the latest Roborun+(ver 1.5) software with VBL2360 and could not find option 'JOIN'.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #29531245 by TechSupport
This thread was talking about the SBL1360 and not the VBL2360 so that is why it was answered in that manner.

You can copy the current tree files from this install, place it somewhere easy to find and then uninstall this version of roborun and install the older version. Then overwrite the tree files with the ones from the new.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.135 seconds
Go to top