Menu

Topic-icon SBL2360 isn´t reading hall sensors

More
9 months 1 week ago #29534361 by LuisRuiz
Hello

I'm working with a SBL2360 connected to two brushless motors from "Oriental Motor" model: BLHM5100K-GFS ( catalog.orientalmotor.com/item/gearheads...heads/blhm5100kc-gfs ).

I tested the motors with the SBL2360 controller and the original Oriental Motor controller ( catalog.orientalmotor.com/item/all-categ...controllers/blhd100k ).
Also I test them in a Chinese driver and it's also working, but when I run them into the RoboteQ driver they don't respond in a trapezoidal or sinusoidal mode.

I check the hall sensors connected to the Oriental Motors driver with oscilloscope and they looks well pulsing, but when the sensors are connected in the SBL2360 they don't respond and only stay in low level.

Is it something about the inputs of the hall sensor in the driver?

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #29534363 by LuisRuiz
Solved!

Please Log in or Create an account to join the conversation.

More
9 months 5 days ago #29534392 by Gabriel_Isko
Glad you solved it, what ended up being the problem? We see a lot of issues with the hall labeling on oriental motors, so any insight into them would be appreciated.

Please Log in or Create an account to join the conversation.

More
9 months 22 hours ago #29534409 by LuisRuiz
It was all about the connection, I took reference with a Chinese controller so the cable colors were wrong. I got the original Oriental motor driver and took reference.

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #29534424 by Gabriel_Isko
Sounds good, we have had a few problems with the labeling on oriental motors. You can also always change the order of the hall sensor order by modifying the Hall Sensor Map setting in the configuration tab of Roborun+.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.109 seconds
Go to top