Menu

Topic-icon CAN Issues

More
3 years 3 weeks ago #29532531 by mrosenfield
CAN Issues was created by mrosenfield
I have a MDC2230S, running V1.7 firmware. Set up for MiniCAN. Connected to Roborun thru serial port.
I have CAN sniffer on the CAN bus. I see that the MDC is transmitting data continually on 0x182,0x282,0x382m 0x482. Data is all zeros.
I have the node ID set to 2, so that makes sense. However, I am running no script, and Heartbeat and MiniCAN Send Rate are set to 0.
Why am I seeing transmissions?

Thank you.

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #29532533 by mrosenfield
Replied by mrosenfield on topic CAN Issues
I cycled the power to the controller, and now it is not transmitting spurious data. Does the power need to be cycled after changing Config settings in Roborun?

I am interfacing to a Racelogic VBox using CAN bus. They transmit data with MSB first. I've been reading up on CAN specs, and apparently CAN data can be either MSB or LSB first - choice is left to the designer. It appears that the Roboteq controller expects data to be ONLY LSB first, which means MSB first data has to be done manually with RawCAN.
Is this true? If so, the option needs to be added in Config to change the byte order.

Second, I don't see any reference to a CAN termination resistor on the controller. which means that I'll have to add one at the cable connector, which is a big pain. Can this be added to the PCB?

Thank you.

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #29532534 by niko
Replied by niko on topic CAN Issues
Hi,

I cannot replicate what you mentioned about TPDOs with mini CAN send Rate to 0. Try to recall any other clue that might help us.

If none of the supported protocols match your specifications you can use RawCAN and process the received data using a script. Check user manual Section 14 for more details.

If something is unclear let us know.

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #29532535 by mrosenfield
Replied by mrosenfield on topic CAN Issues
Is it necessary to cycle the power after changing config settings in Roborun? The problem has not returned after I powered things up this morning.

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #29532537 by niko
Replied by niko on topic CAN Issues
No it is not necessary. I can only assume that somehow configuration changed without being saved, so after restart this change was lost.

Please Log in or Create an account to join the conversation.

Moderators: tonysantoni
Time to create page: 0.090 seconds
Go to top